{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2023-32803 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2023-32803 is a high-severity vulnerability in Amazon ca-certificates, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-32803 and fix it if it is affected.\n\nWhat it is: CVE-2023-32803 is a high-severity vulnerability in Amazon ca-certificates, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-32803 in the wild and no public exploit code.\n\nAffected product: Amazon ca-certificates. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32803/ (Markdown: https://insights.sbomify.com/CVE-2023-32803/index.md)","id":"CVE-2023-32803","markdown":"https://insights.sbomify.com/CVE-2023-32803/index.md","name":"CVE-2023-32803","record":{"aliases":["GHSA-79p4-8vg6-qh65","RHSA-2026:40570"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Amazon Linux certificates","requires_auth":"none","summary":"Amazon Linux 2 fails to remove untrusted TrustCor root certificates, allowing potential trust of malicious entities.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-669","name":"Incorrect Resource Transfer Between Spheres"}],"description":"The ca-certificates package before ca-certificates-2021.2.50-72 for Amazon Linux 2 (AL2) does not properly remove certain TrustCor root certificates from the root store. NOTE: this issue exists because of an incorrect fix for CVE-2022-23491.","ecosystems":["Red Hat:hummingbird:1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Misconfiguration in ca-certificates","id":"CVE-2023-32803","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"misconfiguration","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Mali GPU Userspace Driver can make an Out-of-Bounds access","id":"CVE-2023-32804"},"packages":[{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:2025.2.80_v9.0.304-9.hum1"],"introduced":["0"],"last_affected":[],"package":"ca-certificates","purl":"pkg:rpm/redhat/ca-certificates","source":"RHSA-2026:40570"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:2025.2.80_v9.0.304-9.hum1"],"introduced":["0"],"last_affected":[],"package":"ca-certificates-bundle","purl":"pkg:rpm/redhat/ca-certificates-bundle","source":"RHSA-2026:40570"}],"prev":{"headline":"WordPress WooCommerce Pre-Orders Plugin \u003c= 1.9.0 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-32802"},"products":["ca-certificates"],"published":"2026-09-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-14","vendors":["Amazon"]},"summary":"Amazon Linux 2 fails to remove untrusted TrustCor root certificates, allowing potential trust of malicious entities.","url":"https://insights.sbomify.com/CVE-2023-32803/"}