# CVE-2023-32981: Jenkins Pipeline Utility Steps Plugin arbitrary file write vulnerability

> Attackers can write arbitrary files to the agent file system via crafted archives, potentially leading to code execution or data modification.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 May 2023
- **Updated:** 23 Jan 2025
- **Also known as:** GHSA-6987-xccv-fhjp

## What is CVE-2023-32981?

CVE-2023-32981 is a high-severity path traversal vulnerability in Jenkins Pipeline Utility Steps Plugin, published on 16 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An arbitrary file write vulnerability in Jenkins Pipeline Utility Steps Plugin 2.15.2 and earlier allows attackers able to provide crafted archives as parameters to create or replace arbitrary files on the agent file system with attacker-specified content.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2023-32981?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:pipeline-utility-steps. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:pipeline-utility-steps` | Maven | All versions | 2.15.3 |
| `org.jenkins-ci.plugins:pipeline-utility-steps` | Maven | All versions | 2.15.3 |

Products: Jenkins Pipeline Utility Steps.

## How do I fix CVE-2023-32981?

Upgrade org.jenkins-ci.plugins:pipeline-utility-steps to 2.15.3 or later.

## Is CVE-2023-32981 being exploited?

There is no known exploitation of CVE-2023-32981 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Pipeline Utility Steps Plugin

- [CVE-2022-45381](https://insights.sbomify.com/CVE-2022-45381/): Arbitrary file read vulnerability in Jenkins Pipeline Utility Steps Plugin (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32981 and fix it if it is affected.

What it is: CVE-2023-32981 is a high-severity path traversal vulnerability in Jenkins Pipeline Utility Steps Plugin, published on 16 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-32981 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:pipeline-utility-steps (Maven): affected all versions; fixed in 2.15.3
- org.jenkins-ci.plugins:pipeline-utility-steps (Maven): affected all versions; fixed in 2.15.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32981/ (Markdown: https://insights.sbomify.com/CVE-2023-32981/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32981
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32981
- OSV: https://osv.dev/vulnerability/CVE-2023-32981

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32981/
Summaries are generated and may contain mistakes; the official description above is the record.
