# CVE-2023-32984: Jenkins TestNG Results Plugin Stored Cross-site Scripting vulnerability

> Attackers can inject malicious scripts via crafted TestNG report files, leading to stored XSS in Jenkins.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 May 2023
- **Updated:** 23 Jan 2025
- **Also known as:** GHSA-h3hg-r97v-5r9w

## What is CVE-2023-32984?

CVE-2023-32984 is a medium-severity cross-site scripting vulnerability in Jenkins TestNG Results Plugin, published on 16 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins TestNG Results Plugin 730.v4c5283037693 and earlier does not escape several values that are parsed from TestNG report files and displayed on the plugin's test information pages, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide a crafted TestNG report file.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-32984?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:testng-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:testng-plugin` | Maven | All versions | 730.732.v959a |
| `org.jenkins-ci.plugins:testng-plugin` | Maven | All versions | 730.732.v959a |

Products: Jenkins Testng Results.

## How do I fix CVE-2023-32984?

Upgrade org.jenkins-ci.plugins:testng-plugin to 730.732.v959a or later.

## Is CVE-2023-32984 being exploited?

There is no known exploitation of CVE-2023-32984 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins TestNG Results Plugin

- [CVE-2022-34778](https://insights.sbomify.com/CVE-2022-34778/): Cross-site Scripting in Jenkins TestNG Results Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32984 and fix it if it is affected.

What it is: CVE-2023-32984 is a medium-severity cross-site scripting vulnerability in Jenkins TestNG Results Plugin, published on 16 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-32984 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:testng-plugin (Maven): affected all versions; fixed in 730.732.v959a
- org.jenkins-ci.plugins:testng-plugin (Maven): affected all versions; fixed in 730.732.v959a

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32984/ (Markdown: https://insights.sbomify.com/CVE-2023-32984/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32984
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32984
- OSV: https://osv.dev/vulnerability/CVE-2023-32984

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32984/
Summaries are generated and may contain mistakes; the official description above is the record.
