# CVE-2023-32985: Jenkins Sidebar Link Plugin vulnerable to Path Traversal

> Attackers with Read permission can check for the existence of arbitrary files on the Jenkins controller file system via the Sidebar Link Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 May 2023
- **Updated:** 23 Jan 2025
- **Also known as:** GHSA-pp8m-prr7-wr8w

## What is CVE-2023-32985?

CVE-2023-32985 is a medium-severity path traversal vulnerability in Jenkins Sidebar Link Plugin, published on 16 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Sidebar Link Plugin 2.2.1 and earlier does not restrict the path of files in a method implementing form validation, allowing attackers with Overall/Read permission to check for the existence of an attacker-specified file path on the Jenkins controller file system.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-32985?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:sidebar-link. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:sidebar-link` | Maven | All versions | 2.2.2 |
| `org.jenkins-ci.plugins:sidebar-link` | Maven | All versions | 2.2.2 |

Products: Jenkins Sidebar Link.

## How do I fix CVE-2023-32985?

Upgrade org.jenkins-ci.plugins:sidebar-link to 2.2.2 or later.

## Is CVE-2023-32985 being exploited?

There is no known exploitation of CVE-2023-32985 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Sidebar Link Plugin

- [CVE-2017-1000088](https://insights.sbomify.com/CVE-2017-1000088/): Persisted XSS Vulnerability in Jenkins Sidebar Link Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32985 and fix it if it is affected.

What it is: CVE-2023-32985 is a medium-severity path traversal vulnerability in Jenkins Sidebar Link Plugin, published on 16 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-32985 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:sidebar-link (Maven): affected all versions; fixed in 2.2.2
- org.jenkins-ci.plugins:sidebar-link (Maven): affected all versions; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32985/ (Markdown: https://insights.sbomify.com/CVE-2023-32985/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32985
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32985
- OSV: https://osv.dev/vulnerability/CVE-2023-32985

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32985/
Summaries are generated and may contain mistakes; the official description above is the record.
