{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:reverse-proxy-auth-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-32987 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:reverse-proxy-auth-plugin to 1.7.5 or later.","what":"CVE-2023-32987 is a high-severity vulnerability in Jenkins Reverse Proxy Auth Plugin, published on 16 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-32987 and fix it if it is affected.\n\nWhat it is: CVE-2023-32987 is a high-severity vulnerability in Jenkins Reverse Proxy Auth Plugin, published on 16 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-32987 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:reverse-proxy-auth-plugin (Maven): affected all versions; fixed in 1.7.5\n- org.jenkins-ci.plugins:reverse-proxy-auth-plugin (Maven): affected all versions; fixed in 1.7.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32987/ (Markdown: https://insights.sbomify.com/CVE-2023-32987/index.md)","id":"CVE-2023-32987","markdown":"https://insights.sbomify.com/CVE-2023-32987/index.md","name":"CVE-2023-32987","record":{"aliases":["GHSA-pmmr-r9v2-59p8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Reverse Proxy Auth Plugin","requires_auth":"none","summary":"Attackers can force users to connect to malicious LDAP servers via CSRF, potentially exposing credentials or bypassing authentication in Jenkins.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"reverse_proxy_auth","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Reverse Proxy Auth Plugin 1.7.4 and earlier allows attackers to connect to an attacker-specified LDAP server using attacker-specified credentials.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Reverse Proxy Auth Plugin cross-site request forgery vulnerability","id":"CVE-2023-32987","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Azure VM Agents Plugin missing permission checks","id":"CVE-2023-32988"},"packages":[{"ecosystem":"Maven","fixed":["1.7.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:reverse-proxy-auth-plugin","purl":null,"source":"GHSA-pmmr-r9v2-59p8"},{"ecosystem":"Maven","fixed":["1.7.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:reverse-proxy-auth-plugin","purl":"pkg:maven/org.jenkins-ci.plugins/reverse-proxy-auth-plugin","source":"GHSA-pmmr-r9v2-59p8"}],"prev":{"headline":"Jenkins File Parameter Plugin arbitrary file write vulnerability","id":"CVE-2023-32986"},"products":["Jenkins Reverse Proxy Auth Plugin"],"published":"2023-05-16","related":[{"cvss_score":6.5,"headline":"Jenkins Reverse Proxy Auth Plugin vulnerable due to plaintext storage of passwords","id":"CVE-2022-45384","kev_date_added":null,"published":"2022-11-15"},{"cvss_score":3.3,"headline":"Jenkins Reverse Proxy Auth Plugin allows attackers with local file system access to obtain a list of authorities for logged in users","id":"CVE-2018-1000150","kev_date_added":null,"published":"2018-04-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-23","vendors":["Jenkins Project"]},"summary":"Attackers can force users to connect to malicious LDAP servers via CSRF, potentially exposing credentials or bypassing authentication in Jenkins.","url":"https://insights.sbomify.com/CVE-2023-32987/"}