{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:cas-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-32997 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:cas-plugin to 1.6.3 or later.","what":"CVE-2023-32997 is a high-severity authentication bypass vulnerability in Jenkins CAS Plugin, published on 16 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-32997 and fix it if it is affected.\n\nWhat it is: CVE-2023-32997 is a high-severity authentication bypass vulnerability in Jenkins CAS Plugin, published on 16 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-32997 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:cas-plugin (Maven): affected all versions; fixed in 1.6.3\n- org.jenkins-ci.plugins:cas-plugin (Maven): affected all versions; fixed in 1.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32997/ (Markdown: https://insights.sbomify.com/CVE-2023-32997/index.md)","id":"CVE-2023-32997","markdown":"https://insights.sbomify.com/CVE-2023-32997/index.md","name":"CVE-2023-32997","record":{"aliases":["GHSA-hjh8-9gxh-cx4x"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins CAS Plugin","requires_auth":"none","summary":"Attackers can hijack user sessions in Jenkins CAS Plugin because previous sessions are not invalidated upon login.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"cas","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-384","name":"Session Fixation"}],"description":"Jenkins CAS Plugin 1.6.2 and earlier does not invalidate the previous session on login.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins CAS Plugin Session Fixation vulnerability","id":"CVE-2023-32997","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins AppSpider Plugin Cross-Site Request Forgery vulnerability","id":"CVE-2023-32998"},"packages":[{"ecosystem":"Maven","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:cas-plugin","purl":null,"source":"GHSA-hjh8-9gxh-cx4x"},{"ecosystem":"Maven","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:cas-plugin","purl":"pkg:maven/org.jenkins-ci.plugins/cas-plugin","source":"GHSA-hjh8-9gxh-cx4x"}],"prev":{"headline":"Jenkins SAML Single Sign On(SSO) Plugin missing permission checks","id":"CVE-2023-32996"},"products":["Jenkins CAS Plugin"],"published":"2023-05-16","related":[{"cvss_score":6.1,"headline":"Open redirect vulnerability in Jenkins CAS Plugin","id":"CVE-2021-21673","kev_date_added":null,"published":"2021-06-30"},{"cvss_score":5.4,"headline":"Jenkins CAS Plugin Server-Side Request Forgery vulnerability","id":"CVE-2018-1000188","kev_date_added":null,"published":"2018-06-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-23","vendors":["Jenkins Project"]},"summary":"Attackers can hijack user sessions in Jenkins CAS Plugin because previous sessions are not invalidated upon login.","url":"https://insights.sbomify.com/CVE-2023-32997/"}