# CVE-2023-32997: Jenkins CAS Plugin Session Fixation vulnerability

> Attackers can hijack user sessions in Jenkins CAS Plugin because previous sessions are not invalidated upon login.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 May 2023
- **Updated:** 23 Jan 2025
- **Also known as:** GHSA-hjh8-9gxh-cx4x

## What is CVE-2023-32997?

CVE-2023-32997 is a high-severity authentication bypass vulnerability in Jenkins CAS Plugin, published on 16 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins CAS Plugin 1.6.2 and earlier does not invalidate the previous session on login.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2023-32997?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:cas-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:cas-plugin` | Maven | All versions | 1.6.3 |
| `org.jenkins-ci.plugins:cas-plugin` | Maven | All versions | 1.6.3 |

Products: Jenkins Cas.

## How do I fix CVE-2023-32997?

Upgrade org.jenkins-ci.plugins:cas-plugin to 1.6.3 or later.

## Is CVE-2023-32997 being exploited?

There is no known exploitation of CVE-2023-32997 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins CAS Plugin

- [CVE-2021-21673](https://insights.sbomify.com/CVE-2021-21673/): Open redirect vulnerability in Jenkins CAS Plugin (medium 6.1)
- [CVE-2018-1000188](https://insights.sbomify.com/CVE-2018-1000188/): Jenkins CAS Plugin Server-Side Request Forgery vulnerability (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32997 and fix it if it is affected.

What it is: CVE-2023-32997 is a high-severity authentication bypass vulnerability in Jenkins CAS Plugin, published on 16 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-32997 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:cas-plugin (Maven): affected all versions; fixed in 1.6.3
- org.jenkins-ci.plugins:cas-plugin (Maven): affected all versions; fixed in 1.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32997/ (Markdown: https://insights.sbomify.com/CVE-2023-32997/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32997
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32997
- OSV: https://osv.dev/vulnerability/CVE-2023-32997

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32997/
Summaries are generated and may contain mistakes; the official description above is the record.
