{"answers":{"affected":"2 open source packages ship an affected version, including com.rapid7:jenkinsci-appspider-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-32998 in the wild and no public exploit code.","fix":"Upgrade com.rapid7:jenkinsci-appspider-plugin to 1.0.16 or later.","what":"CVE-2023-32998 is a high-severity vulnerability in Jenkins AppSpider Plugin, published on 16 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-32998 and fix it if it is affected.\n\nWhat it is: CVE-2023-32998 is a high-severity vulnerability in Jenkins AppSpider Plugin, published on 16 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-32998 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.rapid7:jenkinsci-appspider-plugin (Maven): affected all versions; fixed in 1.0.16\n- com.rapid7:jenkinsci-appspider-plugin (Maven): affected all versions; fixed in 1.0.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32998/ (Markdown: https://insights.sbomify.com/CVE-2023-32998/index.md)","id":"CVE-2023-32998","markdown":"https://insights.sbomify.com/CVE-2023-32998/index.md","name":"CVE-2023-32998","record":{"aliases":["GHSA-vgfw-766v-7q82"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins AppSpider Plugin","requires_auth":"none","summary":"Attackers can force users to connect to malicious URLs and send crafted JSON payloads with credentials via CSRF in the Jenkins AppSpider Plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"appspider","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins AppSpider Plugin 1.0.15 and earlier allows attackers to connect to an attacker-specified URL and send an HTTP POST request with a JSON payload consisting of attacker-specified credentials.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins AppSpider Plugin Cross-Site Request Forgery vulnerability","id":"CVE-2023-32998","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins AppSpider Plugin missing permission check","id":"CVE-2023-32999"},"packages":[{"ecosystem":"Maven","fixed":["1.0.16"],"introduced":["0"],"last_affected":[],"package":"com.rapid7:jenkinsci-appspider-plugin","purl":null,"source":"GHSA-vgfw-766v-7q82"},{"ecosystem":"Maven","fixed":["1.0.16"],"introduced":["0"],"last_affected":[],"package":"com.rapid7:jenkinsci-appspider-plugin","purl":"pkg:maven/com.rapid7/jenkinsci-appspider-plugin","source":"GHSA-vgfw-766v-7q82"}],"prev":{"headline":"Jenkins CAS Plugin Session Fixation vulnerability","id":"CVE-2023-32997"},"products":["Jenkins AppSpider Plugin"],"published":"2023-05-16","related":[{"cvss_score":5.5,"headline":"Password stored in plain text by Jenkins AppSpider Plugin","id":"CVE-2020-2314","kev_date_added":null,"published":"2020-11-04"},{"cvss_score":4.3,"headline":"Jenkins AppSpider Plugin does not perform a permission check in a method implementing form validation","id":"CVE-2026-48923","kev_date_added":null,"published":"2026-05-27"},{"cvss_score":4.3,"headline":"Jenkins AppSpider Plugin missing permission checks","id":"CVE-2024-28155","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":4.3,"headline":"Jenkins AppSpider Plugin missing permission check","id":"CVE-2023-32999","kev_date_added":null,"published":"2023-05-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-23","vendors":["Jenkins Project"]},"summary":"Attackers can force users to connect to malicious URLs and send crafted JSON payloads with credentials via CSRF in the Jenkins AppSpider Plugin.","url":"https://insights.sbomify.com/CVE-2023-32998/"}