# CVE-2023-32998: Jenkins AppSpider Plugin Cross-Site Request Forgery vulnerability

> Attackers can force users to connect to malicious URLs and send crafted JSON payloads with credentials via CSRF in the Jenkins AppSpider Plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 May 2023
- **Updated:** 23 Jan 2025
- **Also known as:** GHSA-vgfw-766v-7q82

## What is CVE-2023-32998?

CVE-2023-32998 is a high-severity vulnerability in Jenkins AppSpider Plugin, published on 16 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins AppSpider Plugin 1.0.15 and earlier allows attackers to connect to an attacker-specified URL and send an HTTP POST request with a JSON payload consisting of attacker-specified credentials.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-32998?

2 open source packages ship an affected version, including com.rapid7:jenkinsci-appspider-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.rapid7:jenkinsci-appspider-plugin` | Maven | All versions | 1.0.16 |
| `com.rapid7:jenkinsci-appspider-plugin` | Maven | All versions | 1.0.16 |

Products: Jenkins Appspider.

## How do I fix CVE-2023-32998?

Upgrade com.rapid7:jenkinsci-appspider-plugin to 1.0.16 or later.

## Is CVE-2023-32998 being exploited?

There is no known exploitation of CVE-2023-32998 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins AppSpider Plugin

- [CVE-2020-2314](https://insights.sbomify.com/CVE-2020-2314/): Password stored in plain text by Jenkins AppSpider Plugin (medium 5.5)
- [CVE-2026-48923](https://insights.sbomify.com/CVE-2026-48923/): Jenkins AppSpider Plugin does not perform a permission check in a method implementing form validation (medium 4.3)
- [CVE-2024-28155](https://insights.sbomify.com/CVE-2024-28155/): Jenkins AppSpider Plugin missing permission checks (medium 4.3)
- [CVE-2023-32999](https://insights.sbomify.com/CVE-2023-32999/): Jenkins AppSpider Plugin missing permission check (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32998 and fix it if it is affected.

What it is: CVE-2023-32998 is a high-severity vulnerability in Jenkins AppSpider Plugin, published on 16 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-32998 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.rapid7:jenkinsci-appspider-plugin (Maven): affected all versions; fixed in 1.0.16
- com.rapid7:jenkinsci-appspider-plugin (Maven): affected all versions; fixed in 1.0.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32998/ (Markdown: https://insights.sbomify.com/CVE-2023-32998/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32998
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32998
- OSV: https://osv.dev/vulnerability/CVE-2023-32998

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32998/
Summaries are generated and may contain mistakes; the official description above is the record.
