{"answers":{"affected":"2 open source packages ship an affected version, including com.rapid7:jenkinsci-appspider-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-32999 in the wild and no public exploit code.","fix":"Upgrade com.rapid7:jenkinsci-appspider-plugin to 1.0.16 or later.","what":"CVE-2023-32999 is a medium-severity missing authorization vulnerability in Jenkins AppSpider Plugin, published on 16 May 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-32999 and fix it if it is affected.\n\nWhat it is: CVE-2023-32999 is a medium-severity missing authorization vulnerability in Jenkins AppSpider Plugin, published on 16 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-32999 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.rapid7:jenkinsci-appspider-plugin (Maven): affected all versions; fixed in 1.0.16\n- com.rapid7:jenkinsci-appspider-plugin (Maven): affected all versions; fixed in 1.0.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32999/ (Markdown: https://insights.sbomify.com/CVE-2023-32999/index.md)","id":"CVE-2023-32999","markdown":"https://insights.sbomify.com/CVE-2023-32999/index.md","name":"CVE-2023-32999","record":{"aliases":["GHSA-2c5c-fhr8-pwh9"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins AppSpider Plugin","requires_auth":"low_privilege","summary":"Attackers with read access can force the plugin to send requests to arbitrary URLs with attacker-controlled credentials due to missing permission checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"appspider","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"A missing permission check in Jenkins AppSpider Plugin 1.0.15 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified URL and send an HTTP POST request with a JSON payload consisting of attacker-specified credentials.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins AppSpider Plugin missing permission check","id":"CVE-2023-32999","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins NS-ND Integration Performance Publisher Plugin displays credentials without masking","id":"CVE-2023-33000"},"packages":[{"ecosystem":"Maven","fixed":["1.0.16"],"introduced":["0"],"last_affected":[],"package":"com.rapid7:jenkinsci-appspider-plugin","purl":null,"source":"GHSA-2c5c-fhr8-pwh9"},{"ecosystem":"Maven","fixed":["1.0.16"],"introduced":["0"],"last_affected":[],"package":"com.rapid7:jenkinsci-appspider-plugin","purl":"pkg:maven/com.rapid7/jenkinsci-appspider-plugin","source":"GHSA-2c5c-fhr8-pwh9"}],"prev":{"headline":"Jenkins AppSpider Plugin Cross-Site Request Forgery vulnerability","id":"CVE-2023-32998"},"products":["Jenkins AppSpider Plugin"],"published":"2023-05-16","related":[{"cvss_score":8.8,"headline":"Jenkins AppSpider Plugin Cross-Site Request Forgery vulnerability","id":"CVE-2023-32998","kev_date_added":null,"published":"2023-05-16"},{"cvss_score":5.5,"headline":"Password stored in plain text by Jenkins AppSpider Plugin","id":"CVE-2020-2314","kev_date_added":null,"published":"2020-11-04"},{"cvss_score":4.3,"headline":"Jenkins AppSpider Plugin does not perform a permission check in a method implementing form validation","id":"CVE-2026-48923","kev_date_added":null,"published":"2026-05-27"},{"cvss_score":4.3,"headline":"Jenkins AppSpider Plugin missing permission checks","id":"CVE-2024-28155","kev_date_added":null,"published":"2024-03-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-23","vendors":["Jenkins Project"]},"summary":"Attackers with read access can force the plugin to send requests to arbitrary URLs with attacker-controlled credentials due to missing permission checks.","url":"https://insights.sbomify.com/CVE-2023-32999/"}