CVE-2023-3300 Nomad Search API Leaks Information About CSI Plugins
Unauthenticated users can leak CSI plugin names via the HTTP search API, exposing infrastructure details.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-3300?
CVE-2023-3300 is a medium-severity vulnerability in HashiCorp Nomad, published on 19 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
HashiCorp Nomad and Nomad Enterprise 0.11.0 up to 1.5.6 and 1.4.1 HTTP search API can reveal names of available CSI plugins to unauthenticated users or users without the plugin:read policy. Fixed in 1.6.0, 1.5.7, and 1.4.1.
Which versions are affected by CVE-2023-3300?
5 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/nomad Go | From 0.11.0 | 1.4.11, 1.5.7 |
github.com/hashicorp/nomad Go | From 0.11.0 | 1.4.11 |
github.com/hashicorp/nomad Go | From 0.11.0 | 1.4.11 |
github.com/hashicorp/nomad Go | From 1.5.0 | 1.5.7 |
github.com/hashicorp/nomad Go | From 1.5.0 | 1.5.7 |
Products include Hashicorp Nomad.
How do I fix CVE-2023-3300?
Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.4.11 or 1.5.7.
Is CVE-2023-3300 being exploited?
There is no known exploitation of CVE-2023-3300 in the wild and no public exploit code.
Other vulnerabilities in HashiCorp Nomad
- CVE-2023-1782 Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation
- CVE-2022-30324 Privilege escalation in Hashicorp Nomad
- CVE-2020-7956 Improper Certificate Validation in HashiCorp Nomad
- CVE-2019-12618 Hashicorp Nomad Access Control Issues
- CVE-2020-27195 Use After Free in HashiCorp Nomad
Sources
Also known as GHSA-v5fm-hr72-27hx, GO-2024-2671, UBUNTU-CVE-2023-3300.