# CVE-2023-33008: Apache Johnzon: Prevent inefficient internal conversion from BigDecimal at large scale

> Attackers can cause denial of service by sending JSON with excessively large numbers, forcing slow BigDecimal conversions in Apache Johnzon.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2023
- **Updated:** 7 Oct 2024
- **Also known as:** GHSA-crqg-jrpj-fc84

## What is CVE-2023-33008?

CVE-2023-33008 is a medium-severity denial of service vulnerability in Apache Johnzon, published on 7 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deserialization of Untrusted Data vulnerability in Apache Software Foundation Apache Johnzon.

A malicious attacker can craft up some JSON input that uses large numbers (numbers such as 1e20000000) that Apache Johnzon will deserialize into BigDecimal and maybe use numbers too large which may result in a slow conversion (Denial of service risk). Apache Johnzon 1.2.21 mitigates this by setting a scale limit of 1000 (by default) to the BigDecimal. 

This issue affects Apache Johnzon: through 1.2.20.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-33008?

2 open source packages ship an affected version, including org.apache.johnzon:johnzon-mapper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.johnzon:johnzon-mapper` | Maven | All versions | 1.2.21 |
| `org.apache.johnzon:johnzon-mapper` | Maven | All versions | 1.2.21 |

Products: Apache Johnzon.

## How do I fix CVE-2023-33008?

Upgrade org.apache.johnzon:johnzon-mapper to 1.2.21 or later.

## Is CVE-2023-33008 being exploited?

There is no known exploitation of CVE-2023-33008 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33008 and fix it if it is affected.

What it is: CVE-2023-33008 is a medium-severity denial of service vulnerability in Apache Johnzon, published on 7 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-33008 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.johnzon:johnzon-mapper (Maven): affected all versions; fixed in 1.2.21
- org.apache.johnzon:johnzon-mapper (Maven): affected all versions; fixed in 1.2.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33008/ (Markdown: https://insights.sbomify.com/CVE-2023-33008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33008
- OSV: https://osv.dev/vulnerability/CVE-2023-33008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33008/
Summaries are generated and may contain mistakes; the official description above is the record.
