# CVE-2023-33175: ToUI allows user-specific variables to be shared between users

> ToUI library allows user-specific variables to be shared between users, potentially exposing sensitive data to other users.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2023
- **Updated:** 10 Jan 2025
- **Also known as:** GHSA-hh7j-pg39-q563, PYSEC-2026-555

## What is CVE-2023-33175?

CVE-2023-33175 is a critical vulnerability in mubarakalmehairbi ToUI, published on 30 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ToUI is a Python package for creating user interfaces (websites and desktop apps) from HTML. ToUI is using Flask-Caching (SimpleCache) to store user variables. Websites that use `Website.user_vars` property. It affects versions 2.0.1 to 2.4.0. This issue has been patched in version 2.4.1.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources), CWE-914 (Improper Control of Dynamically-Identified Variables)

## Which versions are affected by CVE-2023-33175?

3 open source packages ship an affected version, including toui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `toui` | PyPI | From 2.0.1 | 2.4.1 |
| `toui` | PyPI | From 2.0.1 | 2.4.1 |
| `toui` | PyPI | From 2.0.1 | 2.4.1 |

Products: Toui Project Toui.

## How do I fix CVE-2023-33175?

Upgrade toui to 2.4.1 or later.

## Is CVE-2023-33175 being exploited?

There is no known exploitation of CVE-2023-33175 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33175 and fix it if it is affected.

What it is: CVE-2023-33175 is a critical vulnerability in mubarakalmehairbi ToUI, published on 30 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-33175 in the wild and no public exploit code.

Affected packages and fixed versions:
- toui (PyPI): affected from 2.0.1; fixed in 2.4.1
- toui (PyPI): affected from 2.0.1; fixed in 2.4.1
- toui (PyPI): affected from 2.0.1; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33175/ (Markdown: https://insights.sbomify.com/CVE-2023-33175/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33175
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33175
- OSV: https://osv.dev/vulnerability/CVE-2023-33175

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33175/
Summaries are generated and may contain mistakes; the official description above is the record.
