# CVE-2023-33185: Incorrect signature verification in django-ses

> Attackers can bypass AWS signature verification in django-ses by specifying arbitrary public certificates, allowing unauthorized webhook requests.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 May 2023
- **Updated:** 14 Jan 2025
- **Also known as:** GHSA-qg36-9jxh-fj25, PYSEC-2023-82

## What is CVE-2023-33185?

CVE-2023-33185 is a medium-severity vulnerability in django-ses, published on 26 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Django-SES is a drop-in mail backend for Django. The django_ses library implements a mail backend for Django using AWS Simple Email Service. The library exports the `SESEventWebhookView class` intended to receive signed requests from AWS to handle email bounces, subscriptions, etc. These requests are signed by AWS and are verified by django_ses, however the verification of this signature was found to be flawed as it allowed users to specify arbitrary public certificates. This issue was patched in version 3.5.0.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2023-33185?

3 open source packages ship an affected version, including django-ses. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-ses` | PyPI | All versions | 3.5.0 |
| `django-ses` | PyPI | All versions | 3.5.0 |
| `django-ses` | PyPI | All versions | 3.5.0 |

Products: Django-Ses Project Django-Ses.

## How do I fix CVE-2023-33185?

Upgrade django-ses to 3.5.0 or later.

## Is CVE-2023-33185 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-33185 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33185 and fix it if it is affected.

What it is: CVE-2023-33185 is a medium-severity vulnerability in django-ses, published on 26 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-33185 exists.

Affected packages and fixed versions:
- django-ses (PyPI): affected all versions; fixed in 3.5.0
- django-ses (PyPI): affected all versions; fixed in 3.5.0
- django-ses (PyPI): affected all versions; fixed in 3.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33185/ (Markdown: https://insights.sbomify.com/CVE-2023-33185/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33185
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33185
- OSV: https://osv.dev/vulnerability/CVE-2023-33185

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33185/
Summaries are generated and may contain mistakes; the official description above is the record.
