# CVE-2023-33187: highlight vulnerable to cleartext transmission of sensitive information

> Highlight may unintentionally record passwords when users toggle visibility, exposing sensitive data to monitoring logs.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 May 2023
- **Updated:** 14 Jan 2025
- **Also known as:** AZL-36943, GHSA-9qpj-qq2r-5mcc

## What is CVE-2023-33187?

CVE-2023-33187 is a medium-severity vulnerability in highlight, published on 26 May 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Highlight is an open source, full-stack monitoring platform. Highlight may record passwords on customer deployments when a password html input is switched to `type="text"` via a javascript "Show Password" button. This differs from the expected behavior which always obfuscates `type="password"` inputs. A customer may assume that switching to `type="text"` would also not record this input; hence, they would not add additional `highlight-mask` css-class obfuscation to this part of the DOM, resulting in unintentional recording of a password value when a `Show Password` button is used. This issue was patched in version 6.0.0.
This patch tracks changes to the `type` attribute of an input to ensure an input that used to be a `type="password"` continues to be obfuscated.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2023-33187?

2 open source packages ship an affected version, including highlight.run. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `highlight.run` | npm | All versions | 6.0.0 |
| `highlight.run` | npm | All versions | 6.0.0 |

Products: Highlight Highlight.

## How do I fix CVE-2023-33187?

Upgrade highlight.run to 6.0.0 or later.

## Is CVE-2023-33187 being exploited?

There is no known exploitation of CVE-2023-33187 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33187 and fix it if it is affected.

What it is: CVE-2023-33187 is a medium-severity vulnerability in highlight, published on 26 May 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-33187 in the wild and no public exploit code.

Affected packages and fixed versions:
- highlight.run (npm): affected all versions; fixed in 6.0.0
- highlight.run (npm): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33187/ (Markdown: https://insights.sbomify.com/CVE-2023-33187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33187
- OSV: https://osv.dev/vulnerability/CVE-2023-33187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33187/
Summaries are generated and may contain mistakes; the official description above is the record.
