# CVE-2023-33191: kyverno seccomp control can be circumvented

> Attackers can bypass Kyverno seccomp controls in Kubernetes, undermining security policies for users with specific pod security validation enabled.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 May 2023
- **Updated:** 10 Jan 2025
- **Also known as:** GHSA-33hq-f2mf-jm3c, GO-2023-1801

## What is CVE-2023-33191?

CVE-2023-33191 is a medium-severity vulnerability in kyverno, published on 30 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Kyverno is a policy engine designed for Kubernetes. Kyverno seccomp control can be circumvented. Users of the podSecurity `validate.podSecurity` subrule in Kyverno 1.9.2 and 1.9.3 are vulnerable. This issue was patched in version 1.9.4.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-33191?

3 open source packages ship an affected version, including github.com/kyverno/kyverno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | From 1.9.2 | 1.9.4 |
| `github.com/kyverno/kyverno` | Go | From 1.9.2 | 1.9.4 |
| `github.com/kyverno/kyverno` | Go | From 1.9.2 | 1.9.4 |

Products: Nirmata Kyverno.

## How do I fix CVE-2023-33191?

Upgrade github.com/kyverno/kyverno to 1.9.4 or later.

## Is CVE-2023-33191 being exploited?

There is no known exploitation of CVE-2023-33191 in the wild and no public exploit code.

## Other vulnerabilities in kyverno

- [CVE-2024-48921](https://insights.sbomify.com/CVE-2024-48921/): Kyverno's PolicyException objects can be created in any namespace by default (high 8.7)
- [CVE-2023-34091](https://insights.sbomify.com/CVE-2023-34091/): Kyverno resource with a deletionTimestamp may allow policy circumvention (medium 6.5)
- [CVE-2023-42813](https://insights.sbomify.com/CVE-2023-42813/): Denial of service from malicious manifest in kyverno (medium 6.1)
- [CVE-2023-42816](https://insights.sbomify.com/CVE-2023-42816/): Denial of service from malicious signature in kyverno (medium 6.1)
- [CVE-2023-42814](https://insights.sbomify.com/CVE-2023-42814/): Denial of service from malicious image manifest in kyverno (low 3.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33191 and fix it if it is affected.

What it is: CVE-2023-33191 is a medium-severity vulnerability in kyverno, published on 30 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-33191 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected from 1.9.2; fixed in 1.9.4
- github.com/kyverno/kyverno (Go): affected from 1.9.2; fixed in 1.9.4
- github.com/kyverno/kyverno (Go): affected from 1.9.2; fixed in 1.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33191/ (Markdown: https://insights.sbomify.com/CVE-2023-33191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33191
- OSV: https://osv.dev/vulnerability/CVE-2023-33191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33191/
Summaries are generated and may contain mistakes; the official description above is the record.
