{"answers":{"affected":"2 open source packages ship an affected version, including ntpd. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-33192 in the wild and no public exploit code.","fix":"Upgrade ntpd to 0.3.3 or later.","what":"CVE-2023-33192 is a high-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 27 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-33192 and fix it if it is affected.\n\nWhat it is: CVE-2023-33192 is a high-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 27 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-33192 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ntpd (crates.io): affected from 0.3.0; fixed in 0.3.3\n- ntpd (crates.io): affected from 0.3.0; fixed in 0.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-33192/ (Markdown: https://insights.sbomify.com/CVE-2023-33192/index.md)","id":"CVE-2023-33192","markdown":"https://insights.sbomify.com/CVE-2023-33192/index.md","name":"CVE-2023-33192","record":{"aliases":["GHSA-qwhm-h7v3-mrjx"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"NTP server implementation","requires_auth":"none","summary":"An attacker can crash the ntpd-rs server by sending specially crafted NTS packets with invalid cookie lengths, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ntpd-rs","vendor":"tweedegolf"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-130","name":"Improper Handling of Length Parameter Inconsistency"}],"description":"ntpd-rs is an NTP implementation written in Rust. ntpd-rs does not validate the length of NTS cookies in received NTP packets to the server. An attacker can crash the server by sending a specially crafted NTP packet containing a cookie shorter than what the server expects. The server also crashes when it is not configured to handle NTS packets. The issue was caused by improper slice indexing. The indexing operations were replaced by safer alternatives that do not crash the ntpd-rs server process but instead properly handle the error condition. A patch was released in version 0.3.3.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper handling of NTS cookie length that could crash the ntpd-rs server","id":"CVE-2023-33192","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Emby Server Proxy Header Spoofing Vulnerability","id":"CVE-2023-33193"},"packages":[{"ecosystem":"crates.io","fixed":["0.3.3"],"introduced":["0.3.0"],"last_affected":[],"package":"ntpd","purl":null,"source":"GHSA-qwhm-h7v3-mrjx"},{"ecosystem":"crates.io","fixed":["0.3.3"],"introduced":["0.3.0"],"last_affected":[],"package":"ntpd","purl":"pkg:cargo/ntpd","source":"GHSA-qwhm-h7v3-mrjx"}],"prev":{"headline":"kyverno seccomp control can be circumvented","id":"CVE-2023-33191"},"products":["ntpd-rs"],"published":"2023-05-27","related":[{"cvss_score":6.9,"headline":"ntpd-rs affected by excessive CPU load from malformed packets","id":"CVE-2026-26076","kev_date_added":null,"published":"2026-02-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-14","vendors":["pendulum-project"]},"summary":"An attacker can crash the ntpd-rs server by sending specially crafted NTS packets with invalid cookie lengths, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2023-33192/"}