# CVE-2023-33192: Improper handling of NTS cookie length that could crash the ntpd-rs server

> An attacker can crash the ntpd-rs server by sending specially crafted NTS packets with invalid cookie lengths, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2023
- **Updated:** 14 Jan 2025
- **Also known as:** GHSA-qwhm-h7v3-mrjx

## What is CVE-2023-33192?

CVE-2023-33192 is a high-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 27 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ntpd-rs is an NTP implementation written in Rust. ntpd-rs does not validate the length of NTS cookies in received NTP packets to the server. An attacker can crash the server by sending a specially crafted NTP packet containing a cookie shorter than what the server expects. The server also crashes when it is not configured to handle NTS packets. The issue was caused by improper slice indexing. The indexing operations were replaced by safer alternatives that do not crash the ntpd-rs server process but instead properly handle the error condition. A patch was released in version 0.3.3.

Weakness: CWE-130 (Improper Handling of Length Parameter Inconsistency)

## Which versions are affected by CVE-2023-33192?

2 open source packages ship an affected version, including ntpd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ntpd` | crates.io | From 0.3.0 | 0.3.3 |
| `ntpd` | crates.io | From 0.3.0 | 0.3.3 |

Products: Tweedegolf Ntpd-Rs.

## How do I fix CVE-2023-33192?

Upgrade ntpd to 0.3.3 or later.

## Is CVE-2023-33192 being exploited?

There is no known exploitation of CVE-2023-33192 in the wild and no public exploit code.

## Other vulnerabilities in pendulum-project ntpd-rs

- [CVE-2026-26076](https://insights.sbomify.com/CVE-2026-26076/): ntpd-rs affected by excessive CPU load from malformed packets (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33192 and fix it if it is affected.

What it is: CVE-2023-33192 is a high-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 27 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-33192 in the wild and no public exploit code.

Affected packages and fixed versions:
- ntpd (crates.io): affected from 0.3.0; fixed in 0.3.3
- ntpd (crates.io): affected from 0.3.0; fixed in 0.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33192/ (Markdown: https://insights.sbomify.com/CVE-2023-33192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33192
- OSV: https://osv.dev/vulnerability/CVE-2023-33192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33192/
Summaries are generated and may contain mistakes; the official description above is the record.
