CVE-2023-33195 Craft CMS XSS in RSS widget feed

Medium 5.0 Published Updated

An attacker can execute arbitrary scripts in the victim's browser via a malformed RSS feed in the Craft CMS widget.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-33195?

CVE-2023-33195 is a medium-severity cross-site scripting vulnerability in Craftcms Craft Cms, published on 27 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Craft is a CMS for creating custom digital experiences on the web. A malformed RSS feed can deliver an XSS payload. This issue was patched in version 4.4.6.

Weakness: CWE-79

Which versions are affected by CVE-2023-33195?

2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.

PackageAffectedFixed in
craftcms/cms PackagistFrom 4.3.04.4.6
craftcms/cms PackagistFrom 4.3.04.4.6

Products include Craftcms Craft Cms.

How do I fix CVE-2023-33195?

Upgrade craftcms/cms to 4.4.6 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-33195 being exploited?

There is no known exploitation of CVE-2023-33195 in the wild and no public exploit code.

All Craftcms Craft Cms vulnerabilities

Sources

Also known as GHSA-qpgm-gjgf-8c2x.

Is CVE-2023-33195 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free