CVE-2023-33196 Craft CMS stored XSS in review volume

Medium 5.5 Published Updated

Craft CMS allows stored XSS via review volumes, enabling attackers to execute scripts in user browsers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-33196?

CVE-2023-33196 is a medium-severity cross-site scripting vulnerability in Craftcms Craft Cms, published on 26 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Craft is a CMS for creating custom digital experiences. Cross site scripting (XSS) can be triggered by review volumes. This issue has been fixed in version 4.4.7.

Weakness: CWE-79, CWE-80

Which versions are affected by CVE-2023-33196?

2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.

PackageAffectedFixed in
craftcms/cms PackagistFrom 4.0.0-RC14.4.7
craftcms/cms PackagistFrom 4.0.0-RC14.4.7

Products include Craftcms Craft Cms.

How do I fix CVE-2023-33196?

Upgrade craftcms/cms to 4.4.7 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-33196 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-33196 exists.

All Craftcms Craft Cms vulnerabilities

Sources

Also known as GHSA-cjmm-x9x9-m2w5.

Is CVE-2023-33196 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free