CVE-2023-33197 Craft CMS stored XSS in indexedVolumes

Medium 5.5 Published Updated

Attackers can inject malicious scripts via the Update Asset Index utility in Craft CMS, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-33197?

CVE-2023-33197 is a medium-severity cross-site scripting vulnerability in Craftcms Craft Cms, published on 26 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Craft is a CMS for creating custom digital experiences on the web. Cross-site scripting (XSS) can be triggered via the Update Asset Index utility. This issue has been patched in version 4.4.6.

Weakness: CWE-79, CWE-80

Which versions are affected by CVE-2023-33197?

2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.

PackageAffectedFixed in
craftcms/cms PackagistFrom 4.0.0-RC14.4.6
craftcms/cms PackagistFrom 4.0.0-RC14.4.6

Products include Craftcms Craft Cms.

How do I fix CVE-2023-33197?

Upgrade craftcms/cms to 4.4.6 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-33197 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-33197 exists.

All Craftcms Craft Cms vulnerabilities

Sources

Also known as GHSA-6qjx-787v-6pxr.

Is CVE-2023-33197 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free