CVE-2023-33202 Bouncy Castle Denial of Service (DoS)
Attackers can cause a denial of service via crafted ASN.1 data in PEM files, affecting applications using the Bouncy Castle Java library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-33202?
CVE-2023-33202 is a medium-severity denial of service vulnerability in n/a, published on 23 Nov 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Bouncy Castle for Java before 1.73 contains a potential Denial of Service (DoS) issue within the Bouncy Castle org.bouncycastle.openssl.PEMParser class. This class parses OpenSSL PEM encoded streams containing X.509 certificates, PKCS8 encoded keys, and PKCS7 objects. Parsing a file that has crafted ASN.1 data through the PEMParser causes an OutOfMemoryError, which can enable a denial of service attack. (For users of the FIPS Java API: BC-FJA 1.0.2.3 and earlier are affected; BC-FJA 1.0.2.4 is fixed.)
Weakness: CWE-400
Which versions are affected by CVE-2023-33202?
18 open source packages ship an affected version, including org.bouncycastle:bcpkix-jdk18on, org.bouncycastle:bcprov-ext-jdk15on and org.bouncycastle:bcprov-ext-jdk16. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.bouncycastle:bcpkix-jdk18on Maven | All versions | 1.73 |
org.bouncycastle:bcpkix-jdk18on Maven | All versions | 1.73 |
org.bouncycastle:bcprov-ext-jdk15on Maven | All versions | 1.73 |
org.bouncycastle:bcprov-ext-jdk15on Maven | All versions | 1.73 |
org.bouncycastle:bcprov-ext-jdk16 Maven | All versions | 1.73 |
org.bouncycastle:bcprov-ext-jdk16 Maven | All versions | 1.73 |
12 more packages
org.bouncycastle:bcprov-jdk14 Maven | All versions | 1.73 |
org.bouncycastle:bcprov-jdk14 Maven | All versions | 1.73 |
org.bouncycastle:bcprov-jdk15 Maven | All versions | 1.73 |
org.bouncycastle:bcprov-jdk15 Maven | All versions | 1.73 |
org.bouncycastle:bcprov-jdk15on Maven | All versions | None |
org.bouncycastle:bcprov-jdk15on Maven | All versions | None |
org.bouncycastle:bcprov-jdk15to18 Maven | All versions | 1.73 |
org.bouncycastle:bcprov-jdk15to18 Maven | All versions | 1.73 |
org.bouncycastle:bcprov-jdk16 Maven | All versions | 1.73 |
org.bouncycastle:bcprov-jdk16 Maven | All versions | 1.73 |
org.bouncycastle:bcprov-jdk18on Maven | All versions | 1.73 |
org.bouncycastle:bcprov-jdk18on Maven | All versions | 1.73 |
Products include Bouncycastle Bouncy Castle for Java, Bouncycastle Fips Java Api.
How do I fix CVE-2023-33202?
Upgrade org.bouncycastle:bcpkix-jdk18on to 1.73 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-33202 being exploited?
There is no known exploitation of CVE-2023-33202 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2023-33202, GHSA-wjxj-5m7g-mg7q, MINI-mhr8-9463-gwp2, MINI-mxj5-7g88-hmg8, MINI-wqjr-hq5f-5mf2, ROOT-APP-MAVEN-CVE-2023-33202 and 1 more.