# CVE-2023-33234: Apache Airflow CNCF Kubernetes Provider: KubernetesPodOperator RCE via connection configuration

> Privileged users can execute arbitrary code by modifying the xcom sidecar image configuration in the Airflow Kubernetes provider.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2023
- **Updated:** 10 Oct 2024
- **Also known as:** GHSA-2rx4-9f5h-9gjf, PYSEC-2026-1143

## What is CVE-2023-33234?

CVE-2023-33234 is a high-severity code injection vulnerability in Apache Airflow CNCF Kubernetes Provider, published on 30 May 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Arbitrary code execution in Apache Airflow CNCF Kubernetes provider version 5.0.0 allows user to change xcom sidecar image and resources via Airflow connection.

In order to exploit this weakness, a user would already need elevated permissions (Op or Admin) to change the connection object in this manner.  Operators should upgrade to provider version 7.0.0 which has removed the vulnerability.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-33234?

3 open source packages ship an affected version, including apache-airflow-providers-cncf-kubernetes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-cncf-kubernetes` | PyPI | From 5.0.0 | 7.0.0 |
| `apache-airflow-providers-cncf-kubernetes` | PyPI | From 5.0.0 | 7.0.0 |
| `apache-airflow-providers-cncf-kubernetes` | PyPI | From 5.0.0 | 7.0.0 |

Products: Apache Apache-Airflow-Providers-Cncf-Kubernetes.

## How do I fix CVE-2023-33234?

Upgrade apache-airflow-providers-cncf-kubernetes to 7.0.0 or later.

## Is CVE-2023-33234 being exploited?

There is no known exploitation of CVE-2023-33234 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow CNCF Kubernetes Provider

- [CVE-2026-27173](https://insights.sbomify.com/CVE-2026-27173/): Apache Airflow CNCF Kubernetes provider: JWT Token Exposure in KubernetesExecutor Command-Line Arguments (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33234 and fix it if it is affected.

What it is: CVE-2023-33234 is a high-severity code injection vulnerability in Apache Airflow CNCF Kubernetes Provider, published on 30 May 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-33234 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-cncf-kubernetes (PyPI): affected from 5.0.0; fixed in 7.0.0
- apache-airflow-providers-cncf-kubernetes (PyPI): affected from 5.0.0; fixed in 7.0.0
- apache-airflow-providers-cncf-kubernetes (PyPI): affected from 5.0.0; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33234/ (Markdown: https://insights.sbomify.com/CVE-2023-33234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33234
- OSV: https://osv.dev/vulnerability/CVE-2023-33234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33234/
Summaries are generated and may contain mistakes; the official description above is the record.
