CVE-2023-33240 Privilege escalation in n/a

High 7.8 Published Updated

Local attackers can escalate privileges via insecure permissions on a system service executable when installed to a non-default directory.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-33240?

CVE-2023-33240 is a high-severity vulnerability in Foxit Pdf Editor, published on 19 May 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Foxit PDF Reader (12.1.1.15289 and earlier) and Foxit PDF Editor (12.1.1.15289 and all previous 12.x versions, 11.2.5.53785 and all previous 11.x versions, and 10.1.11.37866 and earlier) on Windows allows Local Privilege Escalation when installed to a non-default directory because unprivileged users have access to an executable file of a system service. This is fixed in 12.1.2.

Weakness: CWE-276

Which versions are affected by CVE-2023-33240?

It affects 2 products.

Products include Foxit Pdf Editor, Foxit Pdf Reader.

How do I fix CVE-2023-33240?

No fix has been published for CVE-2023-33240 yet. Limit exposure of the affected software until one is available.

Is CVE-2023-33240 being exploited?

There is no known exploitation of CVE-2023-33240 in the wild and no public exploit code.

All Foxit Pdf Editor vulnerabilities

Sources

Also known as GHSA-fwcg-248m-r4cx.

Is CVE-2023-33240 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free