# CVE-2023-33240: Privilege escalation in n/a

> Local attackers can escalate privileges via insecure permissions on a system service executable when installed to a non-default directory.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 May 2023
- **Updated:** 21 Jan 2025
- **Also known as:** GHSA-fwcg-248m-r4cx

## What is CVE-2023-33240?

CVE-2023-33240 is a high-severity vulnerability in Foxit Pdf Editor, published on 19 May 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Foxit PDF Reader (12.1.1.15289 and earlier) and Foxit PDF Editor (12.1.1.15289 and all previous 12.x versions, 11.2.5.53785 and all previous 11.x versions, and 10.1.11.37866 and earlier) on Windows allows Local Privilege Escalation when installed to a non-default directory because unprivileged users have access to an executable file of a system service. This is fixed in 12.1.2.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2023-33240?

It affects 2 products.


Products: Foxit Pdf Editor, Foxit Pdf Reader.

## How do I fix CVE-2023-33240?

No fix has been published for CVE-2023-33240 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-33240 being exploited?

There is no known exploitation of CVE-2023-33240 in the wild and no public exploit code.

## Other vulnerabilities in Foxit Pdf Editor

- [CVE-2022-28104](https://insights.sbomify.com/CVE-2022-28104/): File upload in n/a (critical 9.8)
- [CVE-2022-24954](https://insights.sbomify.com/CVE-2022-24954/): Memory corruption in n/a (critical 9.8)
- [CVE-2022-24955](https://insights.sbomify.com/CVE-2022-24955/): Other in n/a (critical 9.8)
- [CVE-2026-91798](https://insights.sbomify.com/CVE-2026-91798/): Foxit PDF Editor/Reader Updater Privilege Escalation (high 8.8)
- [CVE-2026-91800](https://insights.sbomify.com/CVE-2026-91800/): Foxit PDF Editor installer local privilege escalation (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33240 and fix it if it is affected.

What it is: CVE-2023-33240 is a high-severity vulnerability in Foxit Pdf Editor, published on 19 May 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-33240 in the wild and no public exploit code.

Affected product: Foxit Pdf Editor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33240/ (Markdown: https://insights.sbomify.com/CVE-2023-33240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33240
- OSV: https://osv.dev/vulnerability/CVE-2023-33240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33240/
Summaries are generated and may contain mistakes; the official description above is the record.
