CVE-2023-33264 Hazelcast vulnerable to unmasked password exposure
Hazelcast Management Center users can view unmasked secrets in member configurations due to improper password masking in configuration routines.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-33264?
CVE-2023-33264 is a medium-severity vulnerability in n/a, published on 22 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Hazelcast through 5.0.4, 5.1 through 5.1.6, and 5.2 through 5.2.3, configuration routines don't mask passwords in the member configuration properly. This allows Hazelcast Management Center users to view some of the secrets.
Weakness: CWE-522
Which versions are affected by CVE-2023-33264?
10 open source packages ship an affected version, including com.hazelcast:hazelcast. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.hazelcast:hazelcast Maven | From 4.0-BETA-1 to 4.2.8 | None |
com.hazelcast:hazelcast Maven | From 4.0-BETA-1 to 4.2.8 | None |
com.hazelcast:hazelcast Maven | From 5.0-BETA-1 | 5.0.5 |
com.hazelcast:hazelcast Maven | From 5.0-BETA-1 | 5.0.5 |
com.hazelcast:hazelcast Maven | From 5.1-BETA-1 | 5.1.6 |
com.hazelcast:hazelcast Maven | From 5.1-BETA-1 | 5.1.6 |
4 more packages
com.hazelcast:hazelcast Maven | From 5.2-BETA-1 | 5.2.4 |
com.hazelcast:hazelcast Maven | From 5.2-BETA-1 | 5.2.4 |
com.hazelcast:hazelcast Maven | From 5.3.0-BETA-1 | 5.3.0 |
com.hazelcast:hazelcast Maven | From 5.3.0-BETA-1 | 5.3.0 |
Products include Hazelcast Hazelcast.
How do I fix CVE-2023-33264?
Upgrade com.hazelcast:hazelcast to a fixed version for your release line: 5.0.5, 5.1.6, 5.2.4 or 5.3.0.
Is CVE-2023-33264 being exploited?
There is no known exploitation of CVE-2023-33264 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-5gj6-62g7-vmgf.