# CVE-2023-33265: Hazelcast Executor Services don't check client permissions properly

> Authenticated users can bypass permission checks to execute arbitrary tasks on cluster members, leading to potential privilege escalation and code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2023
- **Updated:** 28 Oct 2024
- **Also known as:** GHSA-c5vj-wp4v-mmvx

## What is CVE-2023-33265?

CVE-2023-33265 is a high-severity missing authorization vulnerability in n/a, published on 18 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Hazelcast through 5.0.4, 5.1 through 5.1.6, and 5.2 through 5.2.3, executor services don't check client permissions properly, allowing authenticated users to execute tasks on members without the required permissions granted.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-33265?

12 open source packages ship an affected version, including com.hazelcast:hazelcast and com.hazelcast:hazelcast-enterprise. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.hazelcast:hazelcast` | Maven | All versions | 5.0.5 |
| `com.hazelcast:hazelcast` | Maven | All versions | 5.0.5 |
| `com.hazelcast:hazelcast` | Maven | From 5.1.0 | 5.1.7 |
| `com.hazelcast:hazelcast` | Maven | From 5.1.0 | 5.1.7 |
| `com.hazelcast:hazelcast` | Maven | From 5.2.0 | 5.2.4 |
| `com.hazelcast:hazelcast` | Maven | From 5.2.0 | 5.2.4 |
| `com.hazelcast:hazelcast-enterprise` | Maven | All versions | 5.0.5 |
| `com.hazelcast:hazelcast-enterprise` | Maven | All versions | 5.0.5 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 5.1.0 | 5.1.7 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 5.1.0 | 5.1.7 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 5.2.0 | 5.2.4 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 5.2.0 | 5.2.4 |

Products: Hazelcast Hazelcast, Hazelcast Imdg.

## How do I fix CVE-2023-33265?

Upgrade com.hazelcast:hazelcast to a fixed version for your release line: 5.0.5, 5.1.7 or 5.2.4.

## Is CVE-2023-33265 being exploited?

There is no known exploitation of CVE-2023-33265 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-26168](https://insights.sbomify.com/CVE-2020-26168/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-36437](https://insights.sbomify.com/CVE-2022-36437/): Hazelcast connection caching (critical 9.1)
- [CVE-2016-10750](https://insights.sbomify.com/CVE-2016-10750/): Deserialization of Untrusted Data in Hazelcast (high 8.1)
- [CVE-2023-45859](https://insights.sbomify.com/CVE-2023-45859/): Missing permission checks on Hazelcast client protocol (high 7.6)
- [CVE-2022-0265](https://insights.sbomify.com/CVE-2022-0265/): Improper Restriction of XML External Entity Reference in hazelcast/hazelcast (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33265 and fix it if it is affected.

What it is: CVE-2023-33265 is a high-severity missing authorization vulnerability in n/a, published on 18 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-33265 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.hazelcast:hazelcast (Maven): affected all versions; fixed in 5.0.5
- com.hazelcast:hazelcast (Maven): affected all versions; fixed in 5.0.5
- com.hazelcast:hazelcast (Maven): affected from 5.1.0; fixed in 5.1.7
- com.hazelcast:hazelcast (Maven): affected from 5.1.0; fixed in 5.1.7
- com.hazelcast:hazelcast (Maven): affected from 5.2.0; fixed in 5.2.4
- com.hazelcast:hazelcast (Maven): affected from 5.2.0; fixed in 5.2.4
- com.hazelcast:hazelcast-enterprise (Maven): affected all versions; fixed in 5.0.5
- com.hazelcast:hazelcast-enterprise (Maven): affected all versions; fixed in 5.0.5
- com.hazelcast:hazelcast-enterprise (Maven): affected from 5.1.0; fixed in 5.1.7
- com.hazelcast:hazelcast-enterprise (Maven): affected from 5.1.0; fixed in 5.1.7
- com.hazelcast:hazelcast-enterprise (Maven): affected from 5.2.0; fixed in 5.2.4
- com.hazelcast:hazelcast-enterprise (Maven): affected from 5.2.0; fixed in 5.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33265/ (Markdown: https://insights.sbomify.com/CVE-2023-33265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33265
- OSV: https://osv.dev/vulnerability/CVE-2023-33265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33265/
Summaries are generated and may contain mistakes; the official description above is the record.
