CVE-2023-3342 User Registration <= 3.0.2 - Authenticated (Subscriber+) Arbitrary File Upload
Authenticated attackers can upload arbitrary files via a hardcoded key and missing validation, potentially leading to remote code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-3342?
CVE-2023-3342 is a critical vulnerability in wpeverest User Registration & Membership – Free & Paid Memberships, Subscriptions, Content Restriction, User Profile, Custom User Registration & Login Builder, published on 13 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The User Registration plugin for WordPress is vulnerable to arbitrary file uploads due to a hardcoded encryption key and missing file type validation on the 'ur_upload_profile_pic' function in versions up to, and including, 3.0.2. This makes it possible for authenticated attackers with subscriber-level capabilities or above to upload arbitrary files on the affected site's server which may make remote code execution possible. This was partially patched in version 3.0.2 and fully patched in version 3.0.2.1.
Weakness: CWE-434
Which versions are affected by CVE-2023-3342?
It affects 1 product.
Products include Wpeverest User Registration.
How do I fix CVE-2023-3342?
No fix has been published for CVE-2023-3342 yet. Limit exposure of the affected software until one is available.
Is CVE-2023-3342 being exploited?
There is no known exploitation of CVE-2023-3342 in the wild and no public exploit code.
Other vulnerabilities in wpeverest User Registration & Membership – Free & Paid Memberships, Subscriptions, Content Restriction, User Profile, Custom User Registration & Login Builder
- CVE-2023-3343 User Registration <= 3.0.1 - Authenticated (Subscriber+) PHP Object Injection
- CVE-2022-3912 User Registration < 2.2.4.1 - Subscriber+ Arbitrary File Upload
- CVE-2025-1511 Cross-site scripting in User Registration & Membership – Free & Paid Memberships, Subscriptions, Content Restriction, User Profile, Custom User Registration & Login Builder
- CVE-2023-23987 WordPress User Registration Plugin <= 2.3.0 is vulnerable to Cross Site Scripting (XSS)
- CVE-2021-24654 User Registration < 2.0.2 - Low Privilege Stored Cross-Site Scripting
Sources
Also known as GHSA-4q7m-mf5f-23v3.