# CVE-2023-33460: Denial of service in n/a

> A memory leak in the YAJL library's tree parsing function can cause out-of-memory conditions and server crashes, leading to denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Jun 2023
- **Updated:** 8 Jan 2025
- **Also known as:** ALPINE-CVE-2023-33460, ALSA-2023:6551, ALSA-2023:7057, AZL-27143, AZL-35363, BELL-CVE-2023-33460, CLSA-2025-1757962664, CLSA-2026-1791454791, DEBIAN-CVE-2023-33460, DLA-3478-1, GHSA-cqgm-m7h3-xgwm, JLSEC-2026-19, RHSA-2023:6551, RHSA-2023:7057, RHSA-2024:2580, RLSA-2023:6551, RLSA-2023:7057, ROOT-OS-ALPINE-318-CVE-2023-33460, RSEC-2023-3, SUSE-SU-2023:3301-1, UBUNTU-CVE-2023-33460, openSUSE-SU-2024:13057-1

## What is CVE-2023-33460?

CVE-2023-33460 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 6 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

There's a memory leak in yajl 2.1.0 with use of yajl_tree_parse function. which will cause out-of-memory in server and cause crash.

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime)

## Which versions are affected by CVE-2023-33460?

1 open source package ship an affected version, including jsonlite. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsonlite` | CRAN | From 0.9.12 | 1.8.8 |
| `yajl` | AlmaLinux:8 | All versions | 2.1.0-12.el8 |
| `yajl-devel` | AlmaLinux:8 | All versions | 2.1.0-12.el8 |
| `yajl` | AlmaLinux:9 | All versions | 2.1.0-22.el9 |
| `yajl-devel` | AlmaLinux:9 | All versions | 2.1.0-22.el9 |
| `yajl` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.1.0-12.el8 |
| `yajl-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.1.0-12.el8 |
| `yajl-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.1.0-12.el8 |
| `yajl-debuginfo` | Red Hat:enterprise_linux:8::crb | All versions | 0:2.1.0-12.el8 |
| `yajl-debugsource` | Red Hat:enterprise_linux:8::crb | All versions | 0:2.1.0-12.el8 |
| `yajl-devel` | Red Hat:enterprise_linux:8::crb | All versions | 0:2.1.0-12.el8 |
| `yajl` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.1.0-22.el9 |
| `yajl-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.1.0-22.el9 |
| `yajl-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.1.0-22.el9 |
| `yajl-debuginfo` | Red Hat:enterprise_linux:9::crb | All versions | 0:2.1.0-22.el9 |
| `yajl-debugsource` | Red Hat:enterprise_linux:9::crb | All versions | 0:2.1.0-22.el9 |
| `yajl-devel` | Red Hat:enterprise_linux:9::crb | All versions | 0:2.1.0-22.el9 |
| `yajl` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:2.1.0-12.el8_8 |
| `yajl-debuginfo` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:2.1.0-12.el8_8 |
| `yajl-debugsource` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:2.1.0-12.el8_8 |
| `yajl-debuginfo` | Red Hat:rhel_eus:8.8::crb | All versions | 0:2.1.0-12.el8_8 |
| `yajl-debugsource` | Red Hat:rhel_eus:8.8::crb | All versions | 0:2.1.0-12.el8_8 |
| `yajl-devel` | Red Hat:rhel_eus:8.8::crb | All versions | 0:2.1.0-12.el8_8 |
| `yajl` | Rocky Linux:8 | All versions | 0:2.1.0-12.el8 |
| `yajl` | Rocky Linux:9 | All versions | 0:2.1.0-22.el9 |
| `libyajl` | SUSE:Linux Enterprise Micro 5.1 | All versions | 2.1.0-150000.4.6.1 |
| `libyajl` | SUSE:Linux Enterprise Micro 5.2 | All versions | 2.1.0-150000.4.6.1 |
| `libyajl` | SUSE:Linux Enterprise Micro 5.3 | All versions | 2.1.0-150000.4.6.1 |
| `libyajl` | SUSE:Linux Enterprise Micro 5.4 | All versions | 2.1.0-150000.4.6.1 |
| `libyajl` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 2.1.0-150000.4.6.1 |
| `libyajl` | SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 2.1.0-150000.4.6.1 |
| `libyajl` | SUSE:Linux Enterprise Real Time 15 SP3 | All versions | 2.1.0-150000.4.6.1 |
| `libyajl` | SUSE:Manager Proxy 4.2 | All versions | 2.1.0-150000.4.6.1 |
| `libyajl` | SUSE:Manager Server 4.2 | All versions | 2.1.0-150000.4.6.1 |
| `libyajl` | openSUSE:Leap 15.4 | All versions | 2.1.0-150000.4.6.1 |
| `libyajl` | openSUSE:Leap 15.5 | All versions | 2.1.0-150000.4.6.1 |
| `libyajl` | openSUSE:Leap Micro 5.3 | All versions | 2.1.0-150000.4.6.1 |
| `libyajl` | openSUSE:Leap Micro 5.4 | All versions | 2.1.0-150000.4.6.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Yajl Project Yajl.

## How do I fix CVE-2023-33460?

Upgrade jsonlite to 1.8.8 or later.

## Is CVE-2023-33460 being exploited?

There is no known exploitation of CVE-2023-33460 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33460 and fix it if it is affected.

What it is: CVE-2023-33460 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 6 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-33460 in the wild and no public exploit code.

Affected packages and fixed versions:
- jsonlite (CRAN): affected from 0.9.12; fixed in 1.8.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33460/ (Markdown: https://insights.sbomify.com/CVE-2023-33460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33460
- OSV: https://osv.dev/vulnerability/CVE-2023-33460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33460/
Summaries are generated and may contain mistakes; the official description above is the record.
