{"answers":{"affected":"2 open source packages ship an affected version, including org.codehaus.janino:janino-parent. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-33546 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2023-33546 is a medium-severity denial of service vulnerability in n/a, published on 1 Jun 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-33546 and fix it if it is affected.\n\nWhat it is: CVE-2023-33546 is a medium-severity denial of service vulnerability in n/a, published on 1 Jun 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-33546 exists.\n\nAffected packages and fixed versions:\n- org.codehaus.janino:janino-parent (Maven): affected all versions up to 3.1.9; no fix listed\n- org.codehaus.janino:janino-parent (Maven): affected all versions up to 3.1.9; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-33546/ (Markdown: https://insights.sbomify.com/CVE-2023-33546/index.md)","id":"CVE-2023-33546","markdown":"https://insights.sbomify.com/CVE-2023-33546/index.md","name":"CVE-2023-33546","record":{"aliases":["DEBIAN-CVE-2023-33546","GHSA-gcg6-xv4f-f749","SUSE-SU-2023:3385-1","openSUSE-SU-2024:13129-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java compiler library","requires_auth":"none","summary":"An attacker can cause a denial of service via stack overflow in Janino's expression evaluator if it processes untrusted input.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"janino","vendor":"janino_project"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Janino 3.1.9 and earlier are subject to denial of service (DOS) attacks when using the expression evaluator.guess parameter name method. If the parser runs on user-supplied input, an attacker could supply content that causes the parser to crash due to a stack overflow. NOTE: this is disputed by multiple parties because Janino is not intended for use with untrusted input.","ecosystems":["Maven","openSUSE:Leap 15.4","openSUSE:Leap 15.5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"janino vulnerable to denial of service due to stack overflow","id":"CVE-2023-33546","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":4,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2023-33548"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["3.1.9"],"package":"org.codehaus.janino:janino-parent","purl":null,"source":"GHSA-gcg6-xv4f-f749"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["3.1.9"],"package":"org.codehaus.janino:janino-parent","purl":"pkg:maven/org.codehaus.janino/janino-parent","source":"GHSA-gcg6-xv4f-f749"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["3.1.10-150200.3.7.1"],"introduced":["0"],"last_affected":[],"package":"janino","purl":"pkg:rpm/opensuse/janino\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2023:3385-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["3.1.10-150200.3.7.1"],"introduced":["0"],"last_affected":[],"package":"janino","purl":"pkg:rpm/opensuse/janino\u0026distro=openSUSE%20Leap%2015.5","source":"SUSE-SU-2023:3385-1"}],"prev":{"headline":"hawtio vulnerable to Path Traversal","id":"CVE-2023-33544"},"products":["n/a"],"published":"2023-06-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"An attacker can cause a denial of service via stack overflow in Janino's expression evaluator if it processes untrusted input.","url":"https://insights.sbomify.com/CVE-2023-33546/"}