# CVE-2023-33568: Dolibarr vulnerable to unauthenticated database access

> Unauthenticated attackers can access sensitive company data including customer, supplier, and employee information via a database dump vulnerability.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2023
- **Updated:** 3 Jan 2025
- **Also known as:** BIT-dolibarr-2023-33568, GHSA-fpvg-m786-h5vr, UBUNTU-CVE-2023-33568

## What is CVE-2023-33568?

CVE-2023-33568 is a high-severity vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 13 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue in Dolibarr 16 before 16.0.5 allows unauthenticated attackers to perform a database dump and access a company's entire customer file, prospects, suppliers, and employee information if a contact file exists.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2023-33568?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | From 16.0.0 | 16.0.5 |
| `dolibarr/dolibarr` | Packagist | From 16.0.0 | 16.0.5 |
| `dolibarr` | Bitnami | From 16.0.0 | 16.0.5 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2023-33568?

Upgrade dolibarr/dolibarr to 16.0.5 or later.

## Is CVE-2023-33568 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-33568 exists.

Public exploit code:

- Dolibarr 16 pre-auth contact database dump (metasploit)
- Dolibarr Unauthenticated Contacts Database Theft (nuclei): http/cves/2023/CVE-2023-33568.yaml

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33568 and fix it if it is affected.

What it is: CVE-2023-33568 is a high-severity vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 13 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-33568 exists.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected from 16.0.0; fixed in 16.0.5
- dolibarr/dolibarr (Packagist): affected from 16.0.0; fixed in 16.0.5
- dolibarr (Bitnami): affected from 16.0.0; fixed in 16.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33568/ (Markdown: https://insights.sbomify.com/CVE-2023-33568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33568
- OSV: https://osv.dev/vulnerability/CVE-2023-33568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33568/
Summaries are generated and may contain mistakes; the official description above is the record.
