CVE-2023-3362 Generation of Error Message Containing Sensitive Information in GitLab
Unauthenticated attackers can access sensitive import error information from GitHub imports in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-3362?
CVE-2023-3362 is a medium-severity vulnerability in Gitlab Gitlab, published on 13 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An information disclosure issue in GitLab CE/EE affecting all versions from 16.0 prior to 16.0.6, and version 16.1.0 allows unauthenticated actors to access the import error information if a project was imported from GitHub.
Weakness: CWE-209
Which versions are affected by CVE-2023-3362?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.0.0 | 16.0.6, 16.1.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-3362?
Upgrade gitlab to a fixed version for your release line: 16.0.6 or 16.1.1.
Is CVE-2023-3362 being exploited?
There is no known exploitation of CVE-2023-3362 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-3362, GHSA-xh3c-jh29-g5wj, UBUNTU-CVE-2023-3362.