# CVE-2023-3385: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab

> An attacker can read unrelated files by uploading a specially crafted file during project import due to a tar bug.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2023
- **Updated:** 20 Nov 2025
- **Also known as:** BIT-gitlab-2023-3385, GHSA-f8q5-vhrp-8mfc, UBUNTU-CVE-2023-3385

## What is CVE-2023-3385?

CVE-2023-3385 is a medium-severity path traversal vulnerability in Gitlab Gitlab, published on 1 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue has been discovered in GitLab affecting all versions starting from 8.10 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. Under specific circumstances, a user importing a project 'from export' could access and read unrelated files via uploading a specially crafted file. This was due to a bug in `tar`, fixed in [`tar-1.35`](https://lists.gnu.org/archive/html/info-gnu/2023-07/msg00005.html).

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-3385?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 8.10.0 | 16.0.8, 16.1.3, 16.2.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2023-3385?

Upgrade gitlab to a fixed version for your release line: 16.0.8, 16.1.3 or 16.2.2.

## Is CVE-2023-3385 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3385 exists.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3385 and fix it if it is affected.

What it is: CVE-2023-3385 is a medium-severity path traversal vulnerability in Gitlab Gitlab, published on 1 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3385 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 8.10.0; fixed in 16.0.8, 16.1.3, 16.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3385/ (Markdown: https://insights.sbomify.com/CVE-2023-3385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3385
- OSV: https://osv.dev/vulnerability/CVE-2023-3385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3385/
Summaries are generated and may contain mistakes; the official description above is the record.
