CVE-2023-33966 Deno missing "--allow-net" permission check for built-in Node modules

High 8.6 Published Updated

Attackers can bypass network permission checks in Deno by using built-in Node modules, allowing unauthorized outbound HTTP requests.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-33966?

CVE-2023-33966 is a high-severity vulnerability in denoland deno, published on 31 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Deno is a runtime for JavaScript and TypeScript. In deno 1.34.0 and deno_runtime 0.114.0, outbound HTTP requests made using the built-in `node:http` or `node:https` modules are incorrectly not checked against the network permission allow list (`--allow-net`). Dependencies relying on these built-in modules are subject to the vulnerability too. Users of Deno versions prior to 1.34.0 are unaffected. Deno Deploy users are unaffected. This problem has been patched in Deno v1.34.1 and deno_runtime 0.114.1 and all users are recommended to update to this version. No workaround is available for this issue.

Weakness: CWE-276, CWE-269

Which versions are affected by CVE-2023-33966?

4 open source packages ship an affected version, including deno and deno_runtime. It affects 2 products.

PackageAffectedFixed in
deno crates.ioFrom 1.34.01.34.1
deno crates.ioFrom 1.34.01.34.1
deno_runtime crates.ioFrom 0.114.00.115.0
deno_runtime crates.ioFrom 0.114.00.115.0

Products include Deno Deno, Deno Deno Runtime.

How do I fix CVE-2023-33966?

Upgrade deno to 1.34.1 or later.

Is CVE-2023-33966 being exploited?

There is no known exploitation of CVE-2023-33966 in the wild and no public exploit code.

Sources

Also known as GHSA-vc52-gwm3-8v2f.

Is CVE-2023-33966 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free