{"answers":{"affected":"4 open source packages ship an affected version, including deno and deno_runtime. It affects 2 products.","exploited":"There is no known exploitation of CVE-2023-33966 in the wild and no public exploit code.","fix":"Upgrade deno to 1.34.1 or later.","what":"CVE-2023-33966 is a high-severity vulnerability in denoland deno, published on 31 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-33966 and fix it if it is affected.\n\nWhat it is: CVE-2023-33966 is a high-severity vulnerability in denoland deno, published on 31 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-33966 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- deno (crates.io): affected from 1.34.0; fixed in 1.34.1\n- deno (crates.io): affected from 1.34.0; fixed in 1.34.1\n- deno_runtime (crates.io): affected from 0.114.0; fixed in 0.115.0\n- deno_runtime (crates.io): affected from 0.114.0; fixed in 0.115.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-33966/ (Markdown: https://insights.sbomify.com/CVE-2023-33966/index.md)","id":"CVE-2023-33966","markdown":"https://insights.sbomify.com/CVE-2023-33966/index.md","name":"CVE-2023-33966","record":{"aliases":["GHSA-vc52-gwm3-8v2f"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript runtime","requires_auth":"none","summary":"Attackers can bypass network permission checks in Deno by using built-in Node modules, allowing unauthorized outbound HTTP requests.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"deno","vendor":"deno"},{"product":"deno_runtime","vendor":"deno"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Deno is a runtime for JavaScript and TypeScript. In deno 1.34.0 and deno_runtime 0.114.0, outbound HTTP requests made using the built-in `node:http` or `node:https` modules are incorrectly not checked against the network permission allow list (`--allow-net`). Dependencies relying on these built-in modules are subject to the vulnerability too. Users of Deno versions prior to 1.34.0 are unaffected. Deno Deploy users are unaffected. This problem has been patched in Deno v1.34.1 and deno_runtime 0.114.1 and all users are recommended to update to this version. No workaround is available for this issue.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deno missing \"--allow-net\" permission check for built-in Node modules","id":"CVE-2023-33966","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"security_feature_bypass","year":"2023"},"n_packages":4,"n_references":2,"next":{"headline":"EaseProbe vulnerable to SQL injection when using MySQL/PostgreSQL data checking","id":"CVE-2023-33967"},"packages":[{"ecosystem":"crates.io","fixed":["1.34.1"],"introduced":["1.34.0"],"last_affected":[],"package":"deno","purl":null,"source":"GHSA-vc52-gwm3-8v2f"},{"ecosystem":"crates.io","fixed":["1.34.1"],"introduced":["1.34.0"],"last_affected":[],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-vc52-gwm3-8v2f"},{"ecosystem":"crates.io","fixed":["0.115.0"],"introduced":["0.114.0"],"last_affected":[],"package":"deno_runtime","purl":null,"source":"GHSA-vc52-gwm3-8v2f"},{"ecosystem":"crates.io","fixed":["0.115.0"],"introduced":["0.114.0"],"last_affected":[],"package":"deno_runtime","purl":"pkg:cargo/deno_runtime","source":"GHSA-vc52-gwm3-8v2f"}],"prev":{"headline":"Brook's tproxy server is vulnerable to a drive-by command injection.","id":"CVE-2023-33965"},"products":["deno"],"published":"2023-05-31","related":[{"cvss_score":10,"headline":"Deno improperly handles resizable ArrayBuffer","id":"CVE-2023-28445","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":10,"headline":"Sandbox bypass leading to arbitrary code execution in Deno","id":"CVE-2022-24783","kev_date_added":null,"published":"2022-03-25"},{"cvss_score":9.8,"headline":"Static imports inside dynamically imported modules do not adhere to permission checks","id":"CVE-2021-32619","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":9.2,"headline":"Deno node:crypto doesn't finalize cipher","id":"CVE-2026-22863","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":8.8,"headline":"Deno interactive permission prompt spoofing via improper ANSI stripping","id":"CVE-2024-27936","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":8.8,"headline":"Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization","id":"CVE-2023-28446","kev_date_added":null,"published":"2023-03-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-09","vendors":["denoland"]},"summary":"Attackers can bypass network permission checks in Deno by using built-in Node modules, allowing unauthorized outbound HTTP requests.","url":"https://insights.sbomify.com/CVE-2023-33966/"}