# CVE-2023-33966: Deno missing "--allow-net" permission check for built-in Node modules

> Attackers can bypass network permission checks in Deno by using built-in Node modules, allowing unauthorized outbound HTTP requests.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2023
- **Updated:** 9 Jan 2025
- **Also known as:** GHSA-vc52-gwm3-8v2f

## What is CVE-2023-33966?

CVE-2023-33966 is a high-severity vulnerability in denoland deno, published on 31 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deno is a runtime for JavaScript and TypeScript. In deno 1.34.0 and deno_runtime 0.114.0, outbound HTTP requests made using the built-in `node:http` or `node:https` modules are incorrectly not checked against the network permission allow list (`--allow-net`). Dependencies relying on these built-in modules are subject to the vulnerability too. Users of Deno versions prior to 1.34.0 are unaffected. Deno Deploy users are unaffected. This problem has been patched in Deno v1.34.1 and deno_runtime 0.114.1 and all users are recommended to update to this version. No workaround is available for this issue.

Weakness: CWE-276 (Incorrect Default Permissions), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-33966?

4 open source packages ship an affected version, including deno and deno_runtime. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | From 1.34.0 | 1.34.1 |
| `deno` | crates.io | From 1.34.0 | 1.34.1 |
| `deno_runtime` | crates.io | From 0.114.0 | 0.115.0 |
| `deno_runtime` | crates.io | From 0.114.0 | 0.115.0 |

Products: Deno Deno, Deno Deno Runtime.

## How do I fix CVE-2023-33966?

Upgrade deno to 1.34.1 or later.

## Is CVE-2023-33966 being exploited?

There is no known exploitation of CVE-2023-33966 in the wild and no public exploit code.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33966 and fix it if it is affected.

What it is: CVE-2023-33966 is a high-severity vulnerability in denoland deno, published on 31 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-33966 in the wild and no public exploit code.

Affected packages and fixed versions:
- deno (crates.io): affected from 1.34.0; fixed in 1.34.1
- deno (crates.io): affected from 1.34.0; fixed in 1.34.1
- deno_runtime (crates.io): affected from 0.114.0; fixed in 0.115.0
- deno_runtime (crates.io): affected from 0.114.0; fixed in 0.115.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33966/ (Markdown: https://insights.sbomify.com/CVE-2023-33966/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33966
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33966
- OSV: https://osv.dev/vulnerability/CVE-2023-33966

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33966/
Summaries are generated and may contain mistakes; the official description above is the record.
