# CVE-2023-33967: EaseProbe vulnerable to SQL injection when using MySQL/PostgreSQL data checking

> Attackers can inject SQL commands via MySQL/PostgreSQL data checking features in EaseProbe, potentially reading or modifying database contents.

- **Severity:** High 8.3 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2023
- **Updated:** 9 Jan 2025
- **Also known as:** GHSA-4c32-w6c7-77x4

## What is CVE-2023-33967?

CVE-2023-33967 is a high-severity SQL injection vulnerability in megaease easeprobe, published on 31 May 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

EaseProbe is a tool that can do health/status checking. An SQL injection issue was discovered in EaseProbe before 2.1.0 when using MySQL/PostgreSQL data checking. This problem has been fixed in v2.1.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-33967?

2 open source packages ship an affected version, including github.com/megaease/easeprobe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/megaease/easeprobe` | Go | All versions | 2.1.0 |
| `github.com/megaease/easeprobe` | Go | All versions | 2.1.0 |

Products: Megaease Easeprobe.

## How do I fix CVE-2023-33967?

Upgrade github.com/megaease/easeprobe to 2.1.0 or later.

## Is CVE-2023-33967 being exploited?

There is no known exploitation of CVE-2023-33967 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33967 and fix it if it is affected.

What it is: CVE-2023-33967 is a high-severity SQL injection vulnerability in megaease easeprobe, published on 31 May 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-33967 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/megaease/easeprobe (Go): affected all versions; fixed in 2.1.0
- github.com/megaease/easeprobe (Go): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33967/ (Markdown: https://insights.sbomify.com/CVE-2023-33967/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33967
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33967
- OSV: https://osv.dev/vulnerability/CVE-2023-33967

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33967/
Summaries are generated and may contain mistakes; the official description above is the record.
