# CVE-2023-33972: Privilege escalation from having CREATE access on a keyspace in Scylladb

> Authenticated users with CREATE access can escalate privileges to read unauthorized tables in the same keyspace.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2023
- **Updated:** 23 Sep 2024
- **Also known as:** BIT-scylladb-2023-33972, GHSA-ww5v-p45p-3vhq

## What is CVE-2023-33972?

CVE-2023-33972 is a high-severity vulnerability in scylladb, published on 27 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Scylladb is a NoSQL data store using the seastar framework, compatible with Apache Cassandra. Authenticated users who are authorized to create tables in a keyspace can escalate their privileges to access a table in the same keyspace, even if they don't have permissions for that table. This issue has not yet been patched. A workaround to address this issue is to disable CREATE privileges on a keyspace, and create new tables on behalf of other users.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-33972?

1 open source package ship an affected version, including scylladb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `scylladb` | Bitnami | All versions | 5.2.9 |

Products: Scylladb Scylladb.

## How do I fix CVE-2023-33972?

Upgrade scylladb to 5.2.9 or later.

## Is CVE-2023-33972 being exploited?

There is no known exploitation of CVE-2023-33972 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33972 and fix it if it is affected.

What it is: CVE-2023-33972 is a high-severity vulnerability in scylladb, published on 27 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-33972 in the wild and no public exploit code.

Affected packages and fixed versions:
- scylladb (Bitnami): affected all versions; fixed in 5.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33972/ (Markdown: https://insights.sbomify.com/CVE-2023-33972/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33972
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33972
- OSV: https://osv.dev/vulnerability/CVE-2023-33972

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33972/
Summaries are generated and may contain mistakes; the official description above is the record.
