# CVE-2023-33976: TensorFlow segfault in array_ops.upper_bound

> An attacker can cause a segmentation fault and denial of service in TensorFlow by providing an invalid tensor rank to the upper_bound operation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** AZL-47242, BIT-tensorflow-2023-33976, GHSA-gjh7-xx4r-x345, PYSEC-2026-1962, PYSEC-2026-3190, PYSEC-2026-3331

## What is CVE-2023-33976?

CVE-2023-33976 is a high-severity vulnerability in Google Tensorflow, published on 30 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TensorFlow is an end-to-end open source platform for machine learning. `array_ops.upper_bound` causes a segfault when not given a rank 2 tensor. The fix will be included in TensorFlow 2.13 and will also cherrypick this commit on TensorFlow 2.12.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2023-33976?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | All versions | 2.12.1 |
| `tensorflow` | PyPI | All versions | 2.12.1 |
| `tensorflow` | PyPI | All versions | 2.12.1 |
| `tensorflow` | PyPI | All versions | 2.12.1 |
| `tensorflow-cpu` | PyPI | All versions | 2.12.1 |
| `tensorflow-cpu` | PyPI | All versions | 2.12.1 |
| `tensorflow-cpu` | PyPI | All versions | 2.12.1 |
| `tensorflow-gpu` | PyPI | All versions | 2.12.1 |
| `tensorflow-gpu` | PyPI | All versions | 2.12.1 |
| `tensorflow-gpu` | PyPI | All versions | 2.12.1 |

Products: Google Tensorflow.

## How do I fix CVE-2023-33976?

Upgrade tensorflow to 2.12.1 or later.

## Is CVE-2023-33976 being exploited?

There is no known exploitation of CVE-2023-33976 in the wild and no public exploit code.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-33976 and fix it if it is affected.

What it is: CVE-2023-33976 is a high-severity vulnerability in Google Tensorflow, published on 30 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-33976 in the wild and no public exploit code.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected all versions; fixed in 2.12.1
- tensorflow (PyPI): affected all versions; fixed in 2.12.1
- tensorflow (PyPI): affected all versions; fixed in 2.12.1
- tensorflow (PyPI): affected all versions; fixed in 2.12.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.12.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.12.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.12.1
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.12.1
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.12.1
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-33976/ (Markdown: https://insights.sbomify.com/CVE-2023-33976/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-33976
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-33976
- OSV: https://osv.dev/vulnerability/CVE-2023-33976

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-33976/
Summaries are generated and may contain mistakes; the official description above is the record.
