CVE-2023-3399 Insertion of Sensitive Information Into Sent Data in GitLab
Unauthorized project or group members can read sensitive CI/CD variables via custom project templates in GitLab Enterprise Edition.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-3399?
CVE-2023-3399 is a high-severity vulnerability in Gitlab Gitlab, published on 6 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab EE affecting all versions starting from 11.6 before 16.3.6, all versions starting from 16.4 before 16.4.2, all versions starting from 16.5 before 16.5.1. It was possible for an unauthorised project or group member to read the CI/CD variables using the custom project templates.
Weakness: CWE-201
Which versions are affected by CVE-2023-3399?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.6.0 | 16.3.6, 16.4.2, 16.5.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-3399?
Upgrade gitlab to a fixed version for your release line: 16.3.6, 16.4.2 or 16.5.1.
Is CVE-2023-3399 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3399 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-3399, GHSA-wrm3-h327-j8wh, UBUNTU-CVE-2023-3399.