{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-34030 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-34030 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-34030 is a medium-severity vulnerability in Really Simple Plugins Complianz, published on 30 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-34030 and fix it if it is affected.\n\nWhat it is: CVE-2023-34030 is a medium-severity vulnerability in Really Simple Plugins Complianz, published on 30 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-34030 in the wild and no public exploit code.\n\nAffected product: Really Simple Plugins Complianz. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34030/ (Markdown: https://insights.sbomify.com/CVE-2023-34030/index.md)","id":"CVE-2023-34030","markdown":"https://insights.sbomify.com/CVE-2023-34030/index.md","name":"CVE-2023-34030","record":{"aliases":["GHSA-3gfw-xw8c-gm3c"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Attackers can trick authenticated users into performing unwanted actions in Complianz plugins, potentially altering privacy settings.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[{"product":"complianz","vendor":"really-simple-plugins"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-Site Request Forgery (CSRF) vulnerability in Really Simple Plugins Complianz, Really Simple Plugins Complianz Premium allows Cross-Site Request Forgery.This issue affects Complianz: from n/a through 6.4.5; Complianz Premium: from n/a through 6.4.7.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"WordPress Complianz and Complianz Premium plugins - Cross Site Request Forgery (CSRF)","id":"CVE-2023-34030","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":0,"n_references":2,"next":{"headline":"WordPress bbPress Toolkit Plugin \u003c= 1.0.12 is vulnerable to Cross Site Request Forgery (CSRF)","id":"CVE-2023-34031"},"packages":[],"prev":{"headline":"WordPress Disable WordPress Update Notifications Plugin \u003c= 2.3.3 is vulnerable to Cross Site Request Forgery (CSRF)","id":"CVE-2023-34029"},"products":["Complianz","Complianz Premium"],"published":"2023-11-30","related":[{"cvss_score":8.8,"headline":"Complianz (Free \u003c 6.3.4, Premium \u003c 6.3.6) - Translator SQLi","id":"CVE-2022-3494","kev_date_added":null,"published":"2022-11-07"},{"cvss_score":7.1,"headline":"Cross-site request forgery in Complianz","id":"CVE-2023-33333","kev_date_added":null,"published":"2023-11-30"},{"cvss_score":6.1,"headline":"Complianz - GDPR/CCPA Cookie Consent \u003c 6.0.0 - Reflected Cross-Site Scripting","id":"CVE-2022-0193","kev_date_added":null,"published":"2022-02-14"},{"cvss_score":5.4,"headline":"Complianz - GDPR/CCPA Cookie Consent \u003c 6.4.2 - Contributor+ Stored XSS","id":"CVE-2023-1069","kev_date_added":null,"published":"2023-03-27"},{"cvss_score":4.4,"headline":"Complianz | GDPR/CCPA Cookie Consent \u003c= 6.5.5 - Authenticated(Administrator+) Stored Cross-site Scripting via settings","id":"CVE-2023-6498","kev_date_added":null,"published":"2024-01-04"},{"cvss_score":4.3,"headline":"Complianz – GDPR/CCPA Cookie Consent \u003c= 6.5.6 - Cross-Site Request Forgery to Data Request Deletion","id":"CVE-2024-1592","kev_date_added":null,"published":"2024-03-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2026-04-28","vendors":["Really Simple Plugins"]},"summary":"Attackers can trick authenticated users into performing unwanted actions in Complianz plugins, potentially altering privacy settings.","url":"https://insights.sbomify.com/CVE-2023-34030/"}