# CVE-2023-34035: Spring Security's authorization rules can be misconfigured when using multiple servlets

> Attackers can bypass authorization rules in Spring Security applications using multiple servlets and specific request matcher configurations.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2023
- **Updated:** 25 Oct 2024
- **Also known as:** GHSA-4vpr-xfrp-cj64

## What is CVE-2023-34035?

CVE-2023-34035 is a high-severity missing authorization vulnerability in Spring Security, published on 18 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Security versions 5.8 prior to 5.8.5, 6.0 prior to 6.0.5, and 6.1 prior to 6.1.2 could be susceptible to authorization rule misconfiguration if the application uses requestMatchers(String) and multiple servlets, one of them being Spring MVC’s DispatcherServlet. (DispatcherServlet is a Spring MVC component that maps HTTP endpoints to methods on @Controller-annotated classes.)

Specifically, an application is vulnerable when all of the following are true:

  *  Spring MVC is on the classpath
  *  Spring Security is securing more than one servlet in a single application (one of them being Spring MVC’s DispatcherServlet)
  *  The application uses requestMatchers(String) to refer to endpoints that are not Spring MVC endpoints

An application is not vulnerable if any of the following is true:

  *  The application does not have Spring MVC on the classpath
  *  The application secures no servlets other than Spring MVC’s DispatcherServlet
  *  The application uses requestMatchers(String) only for Spring MVC endpoints

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-34035?

6 open source packages ship an affected version, including org.springframework.security:spring-security-config. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-config` | Maven | From 5.8.0 | 5.8.5 |
| `org.springframework.security:spring-security-config` | Maven | From 5.8.0 | 5.8.5 |
| `org.springframework.security:spring-security-config` | Maven | From 6.0.0 | 6.0.5 |
| `org.springframework.security:spring-security-config` | Maven | From 6.0.0 | 6.0.5 |
| `org.springframework.security:spring-security-config` | Maven | From 6.1.0 | 6.1.2 |
| `org.springframework.security:spring-security-config` | Maven | From 6.1.0 | 6.1.2 |

Products: Vmware Spring Security.

## How do I fix CVE-2023-34035?

Upgrade org.springframework.security:spring-security-config to a fixed version for your release line: 5.8.5, 6.0.5 or 6.1.2.

## Is CVE-2023-34035 being exploited?

There is no known exploitation of CVE-2023-34035 in the wild and no public exploit code.

Public exploit code:

- https://github.com/jzheaux/cve-2023-34035-mitigations (github_poc): https://github.com/jzheaux/cve-2023-34035-mitigations
- https://github.com/mouadk/CVE-2023-34035-Poc (github_poc): https://github.com/mouadk/CVE-2023-34035-Poc

## Other vulnerabilities in Spring Security

- [CVE-2014-3527](https://insights.sbomify.com/CVE-2014-3527/): Authorization Bypass in Spring Security (critical 9.8)
- [CVE-2026-59354](https://insights.sbomify.com/CVE-2026-59354/): Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata (critical 9.6)
- [CVE-2026-59270](https://insights.sbomify.com/CVE-2026-59270/): Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces (critical 9.4)
- [CVE-2026-22732](https://insights.sbomify.com/CVE-2026-22732/): Under Some Conditions Spring Security HTTP Headers Are not Written (critical 9.1)
- [CVE-2023-34034](https://insights.sbomify.com/CVE-2023-34034/): Access Control Bypass in Spring Security (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34035 and fix it if it is affected.

What it is: CVE-2023-34035 is a high-severity missing authorization vulnerability in Spring Security, published on 18 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34035 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-config (Maven): affected from 5.8.0; fixed in 5.8.5
- org.springframework.security:spring-security-config (Maven): affected from 5.8.0; fixed in 5.8.5
- org.springframework.security:spring-security-config (Maven): affected from 6.0.0; fixed in 6.0.5
- org.springframework.security:spring-security-config (Maven): affected from 6.0.0; fixed in 6.0.5
- org.springframework.security:spring-security-config (Maven): affected from 6.1.0; fixed in 6.1.2
- org.springframework.security:spring-security-config (Maven): affected from 6.1.0; fixed in 6.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34035/ (Markdown: https://insights.sbomify.com/CVE-2023-34035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34035
- OSV: https://osv.dev/vulnerability/CVE-2023-34035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34035/
Summaries are generated and may contain mistakes; the official description above is the record.
