# CVE-2023-34036: Forwarded header exploit with Spring HATEOAS on WebFlux

> Attackers can manipulate hypermedia links in Spring WebFlux applications by spoofing forwarded headers if trusted proxy validation is missing.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2023
- **Updated:** 30 Oct 2024
- **Also known as:** GHSA-7m5c-fgwf-mwph

## What is CVE-2023-34036?

CVE-2023-34036 is a medium-severity vulnerability in Spring HATEOAS, published on 17 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Reactive web applications that use Spring HATEOAS to produce hypermedia-based responses might be exposed to malicious forwarded headers if they are not behind a trusted proxy that ensures correctness of such headers, or if they don't have anything else in place to handle (and possibly discard) forwarded headers either in WebFlux or at the level of the underlying HTTP server.

For the application to be affected, it needs to satisfy the following requirements:

  *  It needs to use the reactive web stack (Spring WebFlux) and Spring HATEOAS to create links in hypermedia-based responses.
  *  The application infrastructure does not guard against clients submitting (X-)Forwarded… headers.

Weakness: CWE-116 (Improper Encoding or Escaping of Output), CWE-644 (Improper Neutralization of HTTP Headers for Scripting Syntax)

## Which versions are affected by CVE-2023-34036?

6 open source packages ship an affected version, including org.springframework.hateoas:spring-hateoas. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.hateoas:spring-hateoas` | Maven | All versions | 1.5.5 |
| `org.springframework.hateoas:spring-hateoas` | Maven | All versions | 1.5.5 |
| `org.springframework.hateoas:spring-hateoas` | Maven | From 2.0.0 | 2.0.5 |
| `org.springframework.hateoas:spring-hateoas` | Maven | From 2.0.0 | 2.0.5 |
| `org.springframework.hateoas:spring-hateoas` | Maven | From 2.1.0 | 2.1.1 |
| `org.springframework.hateoas:spring-hateoas` | Maven | From 2.1.0 | 2.1.1 |

Products: Vmware Spring Hateoas.

## How do I fix CVE-2023-34036?

Upgrade org.springframework.hateoas:spring-hateoas to a fixed version for your release line: 1.5.5, 2.0.5 or 2.1.1.

## Is CVE-2023-34036 being exploited?

There is no known exploitation of CVE-2023-34036 in the wild and no public exploit code.

## Other vulnerabilities in Spring HATEOAS

- [CVE-2026-41006](https://insights.sbomify.com/CVE-2026-41006/): Spring HATEOAS Collection+JSON/UBER deserializers do not honor Jackson configuration (high 7.5)
- [CVE-2026-41007](https://insights.sbomify.com/CVE-2026-41007/): Spring HATEOAS heap exhaustion through unbounded internal caching (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34036 and fix it if it is affected.

What it is: CVE-2023-34036 is a medium-severity vulnerability in Spring HATEOAS, published on 17 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34036 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.hateoas:spring-hateoas (Maven): affected all versions; fixed in 1.5.5
- org.springframework.hateoas:spring-hateoas (Maven): affected all versions; fixed in 1.5.5
- org.springframework.hateoas:spring-hateoas (Maven): affected from 2.0.0; fixed in 2.0.5
- org.springframework.hateoas:spring-hateoas (Maven): affected from 2.0.0; fixed in 2.0.5
- org.springframework.hateoas:spring-hateoas (Maven): affected from 2.1.0; fixed in 2.1.1
- org.springframework.hateoas:spring-hateoas (Maven): affected from 2.1.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34036/ (Markdown: https://insights.sbomify.com/CVE-2023-34036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34036
- OSV: https://osv.dev/vulnerability/CVE-2023-34036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34036/
Summaries are generated and may contain mistakes; the official description above is the record.
