# CVE-2023-34054: Reactor Netty HTTP Server Metrics DoS Vulnerability

> Crafted HTTP requests can cause denial of service in Reactor Netty when Micrometer metrics integration is enabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-q24v-hpg3-v3jp, ROOT-APP-MAVEN-CVE-2023-34054

## What is CVE-2023-34054?

CVE-2023-34054 is a medium-severity denial of service vulnerability in Spring Reactor Netty, published on 28 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Reactor Netty HTTP Server, versions 1.1.x prior to 1.1.13 and versions 1.0.x prior to 1.0.39, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition.

Specifically, an application is vulnerable if Reactor Netty HTTP Server built-in integration with Micrometer is enabled.

## Which versions are affected by CVE-2023-34054?

4 open source packages ship an affected version, including io.projectreactor.netty:reactor-netty-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.projectreactor.netty:reactor-netty-core` | Maven | From 1.0.0 | 1.0.39 |
| `io.projectreactor.netty:reactor-netty-core` | Maven | From 1.0.0 | 1.0.39 |
| `io.projectreactor.netty:reactor-netty-core` | Maven | From 1.1.0 | 1.1.13 |
| `io.projectreactor.netty:reactor-netty-core` | Maven | From 1.1.0 | 1.1.13 |

Products: Broadcom Reactor Netty.

## How do I fix CVE-2023-34054?

Upgrade io.projectreactor.netty:reactor-netty-core to a fixed version for your release line: 1.0.39 or 1.1.13.

## Is CVE-2023-34054 being exploited?

There is no known exploitation of CVE-2023-34054 in the wild and no public exploit code.

## Other vulnerabilities in Spring Reactor Netty

- [CVE-2023-34062](https://insights.sbomify.com/CVE-2023-34062/): In Reactor Netty HTTP Server a malicious user can send a request using a specially crafted URL that can lead to a directory traversal attack (high 7.5)
- [CVE-2019-11284](https://insights.sbomify.com/CVE-2019-11284/): Reactor Netty authentication leak in redirects (medium 6.8)
- [CVE-2020-5403](https://insights.sbomify.com/CVE-2020-5403/): DoS Via Malformed URL with Reactor Netty HTTP Server (medium 6.5)
- [CVE-2020-5404](https://insights.sbomify.com/CVE-2020-5404/): Authentication Leak On Redirect With Reactor Netty HttpClient (medium 6.5)
- [CVE-2026-47848](https://insights.sbomify.com/CVE-2026-47848/): Reactor Netty WebSocket Client Leaks Credentials On Redirect (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34054 and fix it if it is affected.

What it is: CVE-2023-34054 is a medium-severity denial of service vulnerability in Spring Reactor Netty, published on 28 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34054 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.projectreactor.netty:reactor-netty-core (Maven): affected from 1.0.0; fixed in 1.0.39
- io.projectreactor.netty:reactor-netty-core (Maven): affected from 1.0.0; fixed in 1.0.39
- io.projectreactor.netty:reactor-netty-core (Maven): affected from 1.1.0; fixed in 1.1.13
- io.projectreactor.netty:reactor-netty-core (Maven): affected from 1.1.0; fixed in 1.1.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34054/ (Markdown: https://insights.sbomify.com/CVE-2023-34054/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34054
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34054
- OSV: https://osv.dev/vulnerability/CVE-2023-34054

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34054/
Summaries are generated and may contain mistakes; the official description above is the record.
