CVE-2023-34090 Decidim vulnerable to sensitive data disclosure

High 7.5 Published Updated

Unauthenticated attackers can exfiltrate non-public database data via Ransack filtering flaws in Decidim, requiring an upgrade to secure the application.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-34090?

CVE-2023-34090 is a high-severity vulnerability in decidim, published on 11 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. Decidim uses a third-party library named Ransack for filtering certain database collections (e.g., public meetings). By default, this library allows filtering on all data attributes and associations. This allows an unauthenticated remote attacker to exfiltrate non-public data from the underlying database of a Decidim instance (e.g., exfiltrating data from the user table). This issue may lead to Sensitive Data Disclosure. The problem was patched in version 0.27.3.

Weakness: CWE-200

Which versions are affected by CVE-2023-34090?

4 open source packages ship an affected version, including decidim and decidim-meetings. It affects 1 product.

PackageAffectedFixed in
decidim RubyGemsFrom 0.27.00.27.3
decidim RubyGemsFrom 0.27.00.27.3
decidim-meetings RubyGemsFrom 0.27.00.27.3
decidim-meetings RubyGemsFrom 0.27.00.27.3

Products include Decidim Decidim.

How do I fix CVE-2023-34090?

Upgrade decidim to 0.27.3 or later.

Is CVE-2023-34090 being exploited?

There is no known exploitation of CVE-2023-34090 in the wild and no public exploit code.

Sources

Also known as GHSA-jm79-9pm4-vrw9.

Is CVE-2023-34090 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free