{"answers":{"affected":"4 open source packages ship an affected version, including decidim and decidim-meetings. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-34090 in the wild and no public exploit code.","fix":"Upgrade decidim to 0.27.3 or later.","what":"CVE-2023-34090 is a high-severity vulnerability in decidim, published on 11 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-34090 and fix it if it is affected.\n\nWhat it is: CVE-2023-34090 is a high-severity vulnerability in decidim, published on 11 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-34090 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decidim (RubyGems): affected from 0.27.0; fixed in 0.27.3\n- decidim (RubyGems): affected from 0.27.0; fixed in 0.27.3\n- decidim-meetings (RubyGems): affected from 0.27.0; fixed in 0.27.3\n- decidim-meetings (RubyGems): affected from 0.27.0; fixed in 0.27.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34090/ (Markdown: https://insights.sbomify.com/CVE-2023-34090/index.md)","id":"CVE-2023-34090","markdown":"https://insights.sbomify.com/CVE-2023-34090/index.md","name":"CVE-2023-34090","record":{"aliases":["GHSA-jm79-9pm4-vrw9"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy","requires_auth":"none","summary":"Unauthenticated attackers can exfiltrate non-public database data via Ransack filtering flaws in Decidim, requiring an upgrade to secure the application.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"decidim","vendor":"decidim"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. Decidim uses a third-party library named Ransack for filtering certain database collections (e.g., public meetings). By default, this library allows filtering on all data attributes and associations. This allows an unauthenticated remote attacker to exfiltrate non-public data from the underlying database of a Decidim instance (e.g., exfiltrating data from the user table). This issue may lead to Sensitive Data Disclosure. The problem was patched in version 0.27.3.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Decidim vulnerable to sensitive data disclosure","id":"CVE-2023-34090","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2023"},"n_packages":4,"n_references":3,"next":{"headline":"Kyverno resource with a deletionTimestamp may allow policy circumvention","id":"CVE-2023-34091"},"packages":[{"ecosystem":"RubyGems","fixed":["0.27.3"],"introduced":["0.27.0"],"last_affected":[],"package":"decidim","purl":null,"source":"GHSA-jm79-9pm4-vrw9"},{"ecosystem":"RubyGems","fixed":["0.27.3"],"introduced":["0.27.0"],"last_affected":[],"package":"decidim","purl":"pkg:gem/decidim","source":"GHSA-jm79-9pm4-vrw9"},{"ecosystem":"RubyGems","fixed":["0.27.3"],"introduced":["0.27.0"],"last_affected":[],"package":"decidim-meetings","purl":null,"source":"GHSA-jm79-9pm4-vrw9"},{"ecosystem":"RubyGems","fixed":["0.27.3"],"introduced":["0.27.0"],"last_affected":[],"package":"decidim-meetings","purl":"pkg:gem/decidim-meetings","source":"GHSA-jm79-9pm4-vrw9"}],"prev":{"headline":"Decidim Cross-site Scripting vulnerability in the processes filter","id":"CVE-2023-34089"},"products":["decidim"],"published":"2023-07-11","related":[{"cvss_score":9.3,"headline":"Decidim has a Cross-site scripting (XSS) vulnerability via user name field","id":"CVE-2026-23891","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":9.1,"headline":"Decidim has broken access control in templates","id":"CVE-2023-36465","kev_date_added":null,"published":"2023-10-06"},{"cvss_score":8.2,"headline":"Decidim's private data exports can lead to data leaks","id":"CVE-2025-65017","kev_date_added":null,"published":"2026-02-03"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the external link redirections","id":"CVE-2023-32693","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the processes filter","id":"CVE-2023-34089","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":7.7,"headline":"Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds","id":"CVE-2024-45594","kev_date_added":null,"published":"2024-11-13"},{"cvss_score":7.5,"headline":"Decidim amendments can be accepted or rejected by anyone","id":"CVE-2026-40869","kev_date_added":null,"published":"2026-04-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-23","vendors":["decidim"]},"summary":"Unauthenticated attackers can exfiltrate non-public database data via Ransack filtering flaws in Decidim, requiring an upgrade to secure the application.","url":"https://insights.sbomify.com/CVE-2023-34090/"}