# CVE-2023-34092: Vite Server Options (server.fs.deny) can be bypassed using double forward-slash (//)

> Attackers can bypass file access restrictions to read sensitive files from the project root if the Vite dev server is exposed to the network.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2023
- **Updated:** 8 Jan 2025
- **Also known as:** GHSA-353f-5xf4-qw67

## What is CVE-2023-34092?

CVE-2023-34092 is a high-severity path traversal vulnerability in vitejs vite, published on 1 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vite provides frontend tooling. Prior to versions 2.9.16, 3.2.7, 4.0.5, 4.1.5, 4.2.3, and 4.3.9, Vite Server Options (`server.fs.deny`) can be bypassed using double forward-slash (//) allows any unauthenticated user to read file from the Vite root-path of the application including the default `fs.deny` settings (`['.env', '.env.*', '*.{crt,pem}']`). Only users explicitly exposing the Vite dev server to the network (using `--host` or `server.host` config option) are affected, and only files in the immediate Vite project root folder could be exposed. This issue is fixed in vite@4.3.9, vite@4.2.3, vite@4.1.5, vite@4.0.5, vite@3.2.7, and vite@2.9.16.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference), CWE-50 (Path Equivalence: '//multiple/leading/slash'), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-34092?

12 open source packages ship an affected version, including vite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vite` | npm | All versions | 2.9.16 |
| `vite` | npm | All versions | 2.9.16 |
| `vite` | npm | From 3.0.2 | 3.2.7 |
| `vite` | npm | From 3.0.2 | 3.2.7 |
| `vite` | npm | From 4.0.0 | 4.0.5 |
| `vite` | npm | From 4.0.0 | 4.0.5 |
| `vite` | npm | From 4.1.0 | 4.1.5 |
| `vite` | npm | From 4.1.0 | 4.1.5 |
| `vite` | npm | From 4.2.0 | 4.2.3 |
| `vite` | npm | From 4.2.0 | 4.2.3 |
| `vite` | npm | From 4.3.0 | 4.3.9 |
| `vite` | npm | From 4.3.0 | 4.3.9 |

Products: Vitejs Vite.

## How do I fix CVE-2023-34092?

Upgrade vite to a fixed version for your release line: 2.9.16, 3.2.7, 4.0.5 or 4.1.5.

## Is CVE-2023-34092 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34092 exists.

Public exploit code:

- Vite Dev Server - Information Exposure (nuclei): http/cves/2023/CVE-2023-34092.yaml

## Other vulnerabilities in vitejs vite

- [CVE-2025-31125](https://insights.sbomify.com/CVE-2025-31125/): Vite Vitejs Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-53571](https://insights.sbomify.com/CVE-2026-53571/): Vite: `server.fs.deny` bypass on Windows alternate paths (high 8.2)
- [CVE-2026-39363](https://insights.sbomify.com/CVE-2026-39363/): Vite Affected by Arbitrary File Read via Vite Dev Server WebSocket (high 8.2)
- [CVE-2026-39364](https://insights.sbomify.com/CVE-2026-39364/): Vite has a `server.fs.deny` bypass with queries (high 8.2)
- [CVE-2024-23331](https://insights.sbomify.com/CVE-2024-23331/): Vite dev server option `server.fs.deny` can be bypassed when hosted on case-insensitive filesystem (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34092 and fix it if it is affected.

What it is: CVE-2023-34092 is a high-severity path traversal vulnerability in vitejs vite, published on 1 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34092 exists.

Affected packages and fixed versions:
- vite (npm): affected all versions; fixed in 2.9.16
- vite (npm): affected all versions; fixed in 2.9.16
- vite (npm): affected from 3.0.2; fixed in 3.2.7
- vite (npm): affected from 3.0.2; fixed in 3.2.7
- vite (npm): affected from 4.0.0; fixed in 4.0.5
- vite (npm): affected from 4.0.0; fixed in 4.0.5
- vite (npm): affected from 4.1.0; fixed in 4.1.5
- vite (npm): affected from 4.1.0; fixed in 4.1.5
- vite (npm): affected from 4.2.0; fixed in 4.2.3
- vite (npm): affected from 4.2.0; fixed in 4.2.3
- vite (npm): affected from 4.3.0; fixed in 4.3.9
- vite (npm): affected from 4.3.0; fixed in 4.3.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34092/ (Markdown: https://insights.sbomify.com/CVE-2023-34092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34092
- OSV: https://osv.dev/vulnerability/CVE-2023-34092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34092/
Summaries are generated and may contain mistakes; the official description above is the record.
