# CVE-2023-34093: Strapi allows actors to make all attributes on a content-type public without noticing it

> Strapi developers or plugins can inadvertently expose private attributes, leading to sensitive data leaks and potential account takeover.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jul 2023
- **Updated:** 3 Oct 2024
- **Also known as:** GHSA-chmr-rg2f-9jmf

## What is CVE-2023-34093?

CVE-2023-34093 is a medium-severity vulnerability in strapi, published on 25 Jul 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Strapi is an open-source headless content management system. Prior to version 4.10.8, anyone (Strapi developers, users, plugins) can make every attribute of a Content-Type public without knowing it. The vulnerability only affects the handling of content types by Strapi, not the actual content types themselves. Users can use plugins or modify their own content types without realizing that the `privateAttributes` getter is being removed, which can result in any attribute becoming public. This can lead to sensitive information being exposed or the entire system being taken control of by an attacker(having access to password hashes). Anyone can be impacted, depending on how people are using/extending content-types. If the users are mutating the content-type, they will not be affected. Version 4.10.8 contains a patch for this issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-34093?

6 open source packages ship an affected version, including @strapi/database, @strapi/strapi and @strapi/utils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/database` | npm | All versions | 4.10.8 |
| `@strapi/database` | npm | All versions | 4.10.8 |
| `@strapi/strapi` | npm | All versions | 4.10.8 |
| `@strapi/strapi` | npm | All versions | 4.10.8 |
| `@strapi/utils` | npm | All versions | 4.10.8 |
| `@strapi/utils` | npm | All versions | 4.10.8 |

Products: Strapi Strapi.

## How do I fix CVE-2023-34093?

Upgrade @strapi/database to 4.10.8 or later.

## Is CVE-2023-34093 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34093 exists.

## Other vulnerabilities in strapi

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34093 and fix it if it is affected.

What it is: CVE-2023-34093 is a medium-severity vulnerability in strapi, published on 25 Jul 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34093 exists.

Affected packages and fixed versions:
- @strapi/database (npm): affected all versions; fixed in 4.10.8
- @strapi/database (npm): affected all versions; fixed in 4.10.8
- @strapi/strapi (npm): affected all versions; fixed in 4.10.8
- @strapi/strapi (npm): affected all versions; fixed in 4.10.8
- @strapi/utils (npm): affected all versions; fixed in 4.10.8
- @strapi/utils (npm): affected all versions; fixed in 4.10.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34093/ (Markdown: https://insights.sbomify.com/CVE-2023-34093/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34093
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34093
- OSV: https://osv.dev/vulnerability/CVE-2023-34093

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34093/
Summaries are generated and may contain mistakes; the official description above is the record.
