CVE-2023-34098 Dependency configuration exposed in Shopware

Medium 5.3 Published Updated

An attacker can read the package-lock.json file to determine the specific Shopware version, aiding further attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-34098?

CVE-2023-34098 is a medium-severity vulnerability in Shopware Shopware, published on 27 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Shopware is an open source e-commerce software. Due to an incorrect configuration in the `.htaccess` file, the configuration file of the Javascript could be read in production environments (`themes/package-lock.json`). With this information, the specific Shopware version in a deployment might be determined by an attacker, which could be used for further attacks. Users are advised to update to version 5.7.18. There are no known workarounds for this vulnerability.

Weakness: CWE-200

Which versions are affected by CVE-2023-34098?

2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.

PackageAffectedFixed in
shopware/shopware PackagistFrom 5.6.05.7.18
shopware/shopware PackagistFrom 5.6.05.7.18

Products include Shopware Shopware.

How do I fix CVE-2023-34098?

Upgrade shopware/shopware to 5.7.18 or later.

Is CVE-2023-34098 being exploited?

There is no known exploitation of CVE-2023-34098 in the wild and no public exploit code.

All Shopware Shopware vulnerabilities

Sources

Also known as GHSA-q97c-2mh3-pgw9.

Is CVE-2023-34098 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free