# CVE-2023-34098: Dependency configuration exposed in Shopware

> An attacker can read the package-lock.json file to determine the specific Shopware version, aiding further attacks.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2023
- **Updated:** 7 Nov 2024
- **Also known as:** GHSA-q97c-2mh3-pgw9

## What is CVE-2023-34098?

CVE-2023-34098 is a medium-severity vulnerability in Shopware Shopware, published on 27 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Shopware is an open source e-commerce software. Due to an incorrect configuration in the `.htaccess` file, the configuration file of the Javascript could be read in production environments (`themes/package-lock.json`). With this information, the specific Shopware version in a deployment might be determined by an attacker, which could be used for further attacks. Users are advised to update to version 5.7.18. There are no known workarounds for this vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-34098?

2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/shopware` | Packagist | From 5.6.0 | 5.7.18 |
| `shopware/shopware` | Packagist | From 5.6.0 | 5.7.18 |

Products: Shopware Shopware.

## How do I fix CVE-2023-34098?

Upgrade shopware/shopware to 5.7.18 or later.

## Is CVE-2023-34098 being exploited?

There is no known exploitation of CVE-2023-34098 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34098 and fix it if it is affected.

What it is: CVE-2023-34098 is a medium-severity vulnerability in Shopware Shopware, published on 27 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34098 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/shopware (Packagist): affected from 5.6.0; fixed in 5.7.18
- shopware/shopware (Packagist): affected from 5.6.0; fixed in 5.7.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34098/ (Markdown: https://insights.sbomify.com/CVE-2023-34098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34098
- OSV: https://osv.dev/vulnerability/CVE-2023-34098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34098/
Summaries are generated and may contain mistakes; the official description above is the record.
